Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005544TestLinkRequirement Managementpublic2013-03-01 10:392013-05-26 18:50
Reporterstefanbe 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformWindowsOSWindowsOS Version2008 R2
Product Version1.9.5 (2012 Q4 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005544: Requirement version cannot be increased
DescriptionThe versions of requirements cannot be increased anymore. This applies for 1.9.4 as well as 1.9.5.

The problem was also mentioned in the forum by another user:
http://www.teamst.org/forum/viewtopic.php?f=11&t=7239&sid=99bf09dc5e30efd5ecec4b50479ec4b7 [^]

Like this we also cannot import new requirement versions.
Steps To Reproduce- Create a new version for a requirement. You can even try this multiple times.
- Have a look at the version history. All new versions will have number "1"
Additional Informationlib/functions/requirement_mgr.class.php:
Function get_last_child_info

Although there are previous versions in my database this functions returns nothing. So subsequent version numbers will always have number "1".

Also note that we do have custom fields in test cases, maybe there is some relation to that since the code has a comment about it (line 2154, BUGID 2877)
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version5.2.6
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filespng file icon Unbenannt.png [^] (25,850 bytes) 2013-03-01 11:31

- Relationships
duplicate of 0005429closedfman Do not change version of Requirement Operations. 

-  Notes
(0018389)
fman (administrator)
2013-03-01 13:53

without detailed steps one by one to reproduce, no action will be taken.

>> Like this we also cannot import new requirement versions.
two issues on ONE => never this is not our standard => open a different issue for importing with detailed steps to reproduce
(0018390)
stefanbe (reporter)
2013-03-01 14:19

It's the same issue. No new versions for requirements can be added.

Regarding the steps to reproduce the issue: I thought that would be easy to understand. However, I'll try it again :)

1. Login to Testlink
2. Navigate to Requirements Management
3. Select a random requirement (if none exists, create one)
4. Create a new version for that requirement
5. Have a look at the version history of the requirement

Result: The requirement version still is "1"

Expected result: The current requirement version would be "2". And it will be increased anytime you create a new version ("3", "4", "5",...)
(0018391)
fman (administrator)
2013-03-01 15:13

may be 0005429 is a duplicate.
Please check and confirm
(0018392)
stefanbe (reporter)
2013-03-01 15:16

I was searching for a similar issue but didn't find 0005429.

Yes, this one is a duplicate.

I'm glad to read that the issue will be fixed in 1.9.6.

Thank you for your feedback.

- Issue History
Date Modified Username Field Change
2013-03-01 10:39 stefanbe New Issue
2013-03-01 11:31 stefanbe File Added: Unbenannt.png
2013-03-01 13:53 fman Note Added: 0018389
2013-03-01 14:19 stefanbe Note Added: 0018390
2013-03-01 15:13 fman Note Added: 0018391
2013-03-01 15:13 fman Relationship added duplicate of 0005429
2013-03-01 15:16 stefanbe Note Added: 0018392
2013-03-01 15:20 fman Status new => resolved
2013-03-01 15:20 fman Resolution open => duplicate
2013-03-01 15:20 fman Assigned To => fman
2013-03-09 19:06 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2013-05-26 18:50 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker