Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005541TestLinkTest Execute - Filterspublic2013-02-27 15:462013-05-26 18:50
ReporterAdilson1 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSLinuxOS VersionRHEL 5
Product Version1.9.5 (2012 Q4 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005541: BULK Execution - When "Result" filter is used, no test cases show up in the right pane when user clicks on the test suite.
DescriptionIn Test Excution, using the Result filter prevents the list of test cases matching the filter from showing up on the right-pane.

Scenario:
==========
I have 9 or so test cases that are not run under a particular test suite and would like to use the "Result" filter of "Not Run" and mark all matching test cases to "Passed". Currently the right-pane is not populated with the test cases if the "Result" keyword is used.
Steps To Reproduce1.) In Test Execution, set "Result" filter to "Not Run".
2.) Hit the Apply button to get list of results in tree.
3.) In tree, select a test suite with multiple test cases in it.

Note that the list of test cases don't show up on the right-pane.
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL
BrowserChrome
PHP Version5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon testlink-bug.png [^] (343,289 bytes) 2013-02-27 15:46

- Relationships

-  Notes
(0018380)
fman (administrator)
2013-02-27 16:59
edited on: 2013-02-27 16:59

without a detailed steps to reproduce, unfortunately I can not assign time to this issue.
See 0005040 as example

(0018381)
Adilson1 (reporter)
2013-02-27 19:46

Hi, sorry about that, I thought the steps I submitted were enough. Details are below:

I have attached a picture to help describe the problem covering the steps when I submitted the bug.

Setup:
=====
1.) A test suite with at least two test cases in the test suite
2.) Test Plan with the test suite from step 1 above
3.) Assign test cases execution to your user.
 

Reproducing this bug using setup above:

1.) Click on Test Execution after selecting the test plan you added at least two test cases to.
2.) Use arrow on Test Execution page to display Filters.
3.) From the filters page, select "Not Run" from the "Result" drop-down box.
4.) Hit the "Apply" button
5.) After Testlink correctly shows all the matching test suites and test cases in the resulting tree below, click on the test suite that contains at least two test cases.
6.) On the right pane, there should be a list containing both test cases but instead the message "No data available" appears.
(0018399)
fman (administrator)
2013-03-06 19:24
edited on: 2013-03-06 19:54

missing info:
how many builds ?

DO you have configured for bulk execution ?

please understand that I can not start a work anytime, and stop because information provided is incomplete.
I need same (or better) level of information you provide to your developers,
because we can not exchange info in other way that through notes on tickets

Images are ok, but detailed descriptions on notes are a lot much better
to follow step by step and reproduce.

(0018400)
fman (administrator)
2013-03-06 21:42

http://gitorious.org/testlink-ga/testlink-code/commit/942fd9dee4f44f520c5b6dbae101ad9e1984ff26 [^]
(0018431)
Adilson1 (reporter)
2013-03-13 21:36

Hi fman, I tested your fix and it works like a charm. Cheers and thanks for the update.

- Issue History
Date Modified Username Field Change
2013-02-27 15:46 Adilson1 New Issue
2013-02-27 15:46 Adilson1 File Added: testlink-bug.png
2013-02-27 16:59 fman Note Added: 0018380
2013-02-27 16:59 fman Note Edited: 0018380 View Revisions
2013-02-27 19:46 Adilson1 Note Added: 0018381
2013-03-06 19:24 fman Note Added: 0018399
2013-03-06 19:27 fman Note Edited: 0018399 View Revisions
2013-03-06 19:54 fman Note Edited: 0018399 View Revisions
2013-03-06 19:54 fman Summary When "Result" filter is used, no test cases show up in the right pane when user clicks on the test suite. => BULK Execution - When "Result" filter is used, no test cases show up in the right pane when user clicks on the test suite.
2013-03-06 21:41 fman Tag Attached: TO BE FIXED on 2.0
2013-03-06 21:42 fman Note Added: 0018400
2013-03-06 21:42 fman Assigned To => fman
2013-03-06 21:42 fman Status new => feedback
2013-03-09 08:54 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-03-09 08:54 fman Status feedback => resolved
2013-03-09 08:54 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2013-03-09 08:54 fman Resolution open => fixed
2013-03-13 21:36 Adilson1 Note Added: 0018431
2013-05-26 18:50 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker