Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005481TestLinkChartspublic2013-01-17 09:252016-02-19 14:05
Reportertwelve 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.5 (2012 Q4 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005481: Error in pie chart for platforms without testcases
DescriptionAmong other things, the charts report (/lib/results/charts.php?format=0&tplan_id=<ID>) shows a pie chart for every platform. We have a lot of testplans with many platforms, and some testplans may contain platforms that do not have any testcases.
In Testlink 1.9.2 the charts report shows an empty pie chart for such platforms (see attached picture). In the current version of Testlink an error is thrown instead. When opening the pie chart you get the error message "[FATAL] Pie chart can only accept one serie of data."
I believe the old behaviour was nicer.
Steps To Reproduce1. Create a testplan
2. Create a build
3. Create 2 platforms
4. Add both platforms to the testplan
5. Add a testcase to the first platform only
6. Open the charts report
7. The pie chart of the second platform is broken
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL 5.5
Browser
PHP Version5.3
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon piechartold.png [^] (7,253 bytes) 2013-01-17 09:25


png file icon piechartnew.png [^] (643 bytes) 2013-01-21 07:42

- Relationships
child of 0005406closedfman Availables hot-fixes for 1.9.5 & How To get full fixed package from gitorious 

-  Notes
(0018188)
fman (administrator)
2013-01-19 09:28

Unable to reproduce
1. Got Bitnami VM with 1.9.5
2. create test project Bitnami VM on Lenovo L530
3. create just one test suite (Test Suite : QAZ)
with just one test case (BVM-1:QWWS)

4. Create just one test plan (TPLAN-0)
5. Create a Build => 1.0
6. import platforms using example provided with TestLink => romulan-empire-spaceships.xml
7. add only two platforms to test plan => Assault Ships,Couriers
8. link the only available test case to test plan ONLY for Assault Ships platform
DO NOT EXECUTE THE TEST CASE
9. access Test reports and metrics
10. charts
got no error on screen
got title regarding second platform and NO IMAGE

got indications on TestLink Event viewer that need to be fixed
(but this is a different issue)

Tested on Fedora 18 using Firefox 18
(0018198)
twelve (reporter)
2013-01-21 07:42

Hello,

"NO IMAGE" is what I mean (see attached image, "Sparte 8" is a platform without test cases).
In earlier versions the function responsible for creating the image (/lib/results/platformPieChart.php?tplan_id=X&platform_id=Y) did create an empty chart for platforms without test cases as shown in "piechartold.png". In Testlink 1.9.5 the function does not output an image anymore but instead the error message "[FATAL] Pie chart can only accept one serie of data".
(0018202)
fman (administrator)
2013-01-21 11:21

As indicated on 18118 I do not get the error on screen:
[FATAL] Pie chart can only accept one serie of data
(0018203)
twelve (reporter)
2013-01-21 11:45

No, you only see the word "Image" which stands for a broken image, because the webbrowser cannot render "[FATAL] Pie chart can only accept one serie of data" as an image.
If you open the src of the image directly (/lib/results/platformPieChart.php?tplan_id=X&platform_id=Y), you will see the error message.
(0018213)
fman (administrator)
2013-01-23 16:42

>> If you open the src of the image directly (/lib/results
>>/platformPieChart.php?tplan_id=X&platform_id=Y), you will see the error message.
good to know

I was finally able to reproduce
(0018214)
fman (administrator)
2013-01-23 17:02

https://gitorious.org/testlink-ga/testlink-code/commit/7041562553ea893295ba58f11b65f07ecc3bd9fb [^]

- Issue History
Date Modified Username Field Change
2013-01-17 09:25 twelve New Issue
2013-01-17 09:25 twelve File Added: piechartold.png
2013-01-19 09:28 fman Note Added: 0018188
2013-01-19 09:28 fman Assigned To => fman
2013-01-19 09:28 fman Status new => feedback
2013-01-21 07:42 twelve Note Added: 0018198
2013-01-21 07:42 twelve Status feedback => assigned
2013-01-21 07:42 twelve File Added: piechartnew.png
2013-01-21 11:21 fman Note Added: 0018202
2013-01-21 11:45 twelve Note Added: 0018203
2013-01-23 16:42 fman Note Added: 0018213
2013-01-23 17:02 fman Note Added: 0018214
2013-01-23 17:02 fman Tag Attached: TO BE FIXED on 2.0
2013-01-23 17:02 fman Relationship added child of 0005406
2013-01-23 17:03 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2013-01-23 17:03 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-01-23 17:03 fman Status assigned => resolved
2013-01-23 17:03 fman Resolution open => fixed
2013-05-26 18:51 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker