Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005480TestLinkTest Specificationpublic2013-01-16 19:162013-09-09 19:54
Reporterfman 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.5 (2012 Q4 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005480: Possibility to renumber steps to remove 'holes' created due to step delete.
DescriptionSome people has complained about:

>> When inserting steps, their numeration changes automatically.
>> When deleting steps, this does not happens.
>> user has to reorder steps manually after that.

Development position is:
1. step numbering with holes has no drawbacks, because only important thing is step sequence order, no matter if you have step 1, step 4, step 5, step 6.

2. reordering automatically after each step delete, is not wise.

To try to provide a valid workaround, we will provide an option to launch step renumbering/resequencing starting from 1, at user will

TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)N/A
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0005903closedfman Resequence steps button doesn't work 
child of 0005406closedfman Availables hot-fixes for 1.9.5 & How To get full fixed package from gitorious 

-  Notes
(0018179)
fman (administrator)
2013-01-16 19:29

http://gitorious.org/testlink-ga/testlink-code/commit/660ae578d6e11c6575115a6638bdfd6c0067f731 [^]

- Issue History
Date Modified Username Field Change
2013-01-16 19:16 fman New Issue
2013-01-16 19:16 fman Status new => assigned
2013-01-16 19:16 fman Assigned To => fman
2013-01-16 19:29 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-01-16 19:29 fman Status assigned => resolved
2013-01-16 19:29 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2013-01-16 19:29 fman Resolution open => fixed
2013-01-16 19:29 fman Note Added: 0018179
2013-01-16 19:30 fman Tag Attached: TO BE FIXED on 2.0
2013-01-16 19:30 fman Relationship added child of 0005406
2013-05-30 19:41 fman Status resolved => closed
2013-09-09 19:54 fman Relationship added related to 0005903



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker