Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005471TestLinkTest Project Managementpublic2013-01-15 09:302013-05-30 19:41
Reportermbar 
Assigned Tofman 
PriorityurgentSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005471: Can not enter Test Project Management (latest git code)
DescriptionI just installed latest updates from git (I updated our TL codebase from 2012-12-22 to 2013-01-15) as described in 5406 issue.
The main probem now is that Test Project Management functionality is no longer working.

The log:

ERROR ON exec_query() - database.class.php
1146 - Table 'testlink.testproject_reqmgrsystem' doesn't exist - /* Class:testproject - Method: get_accessible_for_user */ SELECT nodes_hierarchy.name,testprojects.* ,ITMD.name AS itname,ITMD.type AS ittype ,RMSMD.name AS rmsname,RMSMD.type AS rmstype FROM nodes_hierarchy nodes_hierarchy JOIN testprojects testprojects ON nodes_hierarchy.id=testprojects.id LEFT OUTER JOIN user_testproject_roles user_testproject_roles ON testprojects.id = user_testproject_roles.testproject_id AND user_testproject_roles.user_id =2 LEFT OUTER JOIN testproject_issuetracker AS TIT ON TIT.testproject_id = testprojects.id LEFT OUTER JOIN issuetrackers AS ITMD ON ITMD.id = TIT.issuetracker_id LEFT OUTER JOIN testproject_reqmgrsystem AS TRMS ON TRMS.testproject_id = testprojects.id LEFT OUTER JOIN reqmgrsystems AS RMSMD ON RMSMD.id = TRMS.reqmgrsystem_id WHERE 1=1 ORDER BY name
THE MESSAGE : /* Class:testproject - Method: get_accessible_for_user */ SELECT nodes_hierarchy.name,testprojects.* ,ITMD.name AS itname,ITMD.type AS ittype ,RMSMD.name AS rmsname,RMSMD.type AS rmstype FROM nodes_hierarchy nodes_hierarchy JOIN testprojects testprojects ON nodes_hierarchy.id=testprojects.id LEFT OUTER JOIN user_testproject_roles user_testproject_roles ON testprojects.id = user_testproject_roles.testproject_id AND user_testproject_roles.user_id =2 LEFT OUTER JOIN testproject_issuetracker AS TIT ON TIT.testproject_id = testprojects.id LEFT OUTER JOIN issuetrackers AS ITMD ON ITMD.id = TIT.issuetracker_id LEFT OUTER JOIN testproject_reqmgrsystem AS TRMS ON TRMS.testproject_id = testprojects.id LEFT OUTER JOIN reqmgrsystems AS RMSMD ON RMSMD.id = TRMS.reqmgrsystem_id WHERE 1=1 ORDER BY name Query failed: errorcode[1146] errormsg:Table 'testlink.testproject_reqmgrsystem' doesn't exist
Steps To Reproduce1. Install latest TL code from git.
2. Login to TL.
3. Click on Test Project Management.
4. Crash: DB Access Error - debug_print_backtrace() OUTPUT START
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0018160)
mbar (reporter)
2013-01-15 09:36

I can see that in Install there is a create_tables script, which ones do I need?
I can't create whole new database on a production system :)
(0018161)
mbar (reporter)
2013-01-15 10:03

Yes, create tables helped, but some kind of readme/notification or howto in 5406 issue would be nice.
(0018170)
fman (administrator)
2013-01-15 21:25
edited on: 2013-01-15 21:27

Code present on testlink_1_9 branch can be unstable, and you have to use the fixes present on 5406, with care.
This line of development contains code that can be unstable.
Because this line of development can contain new features, we can not provide info about how to install it till work is finished.


Regarding
>> I can't create whole new database on a production system :)
you need to be very careful when applying fixes => you need to have a QA system where to apply fixes before applying it on a production one


- Issue History
Date Modified Username Field Change
2013-01-15 09:30 mbar New Issue
2013-01-15 09:36 mbar Note Added: 0018160
2013-01-15 10:03 mbar Note Added: 0018161
2013-01-15 21:25 fman Note Added: 0018170
2013-01-15 21:26 fman Note Added: 0018171
2013-01-15 21:26 fman Status new => resolved
2013-01-15 21:26 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2013-01-15 21:26 fman Resolution open => fixed
2013-01-15 21:26 fman Assigned To => fman
2013-01-15 21:26 fman Product Version 1.9.5 (2012 Q4 - bug fixing) =>
2013-01-15 21:27 fman Note Edited: 0018170 View Revisions
2013-01-15 21:27 fman Note Deleted: 0018171
2013-05-30 19:41 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker