Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005470TestLinkTest Specificationpublic2013-01-15 00:362013-05-30 19:41
Reportervins_14 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.5 (2012 Q4 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005470: Connection timing out while creating/editing test cases
DescriptionI am trying to create/edit a test case that has tables created either in the "Summary" or "Pre conditions" section and when I save the test case, the same fails and a "The connection has timed out" message is displayed on the page.
We had the issue with testlink 1.9 and we upgraded to testlink.1.9.5 and both the versions have the same issue.
We have tried it using different version of the browser (FF 17, Chrome), but it doesn't help.

Here is the URL that timesout: http://<hostname>/testlink/lib/testcases/tcEdit.php [^]

We don't see any errors in the testlink logs.

We have been dealing with this issues for the past 1 month and have tried changing the settings in the php.ini and the my.cnf, but none of the same helped. Has anyone run into this issue? Any suggestions?

Steps To Reproduce- Create or edit an existing test case
- create a table under the "summary" or "pre conditions" section
- save the test case

Actual result:
the page/frame will timeout after 30 seconds.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL 5.1
BrowserFirefox 14
PHP Versionphp 5.2.9
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships

-  Notes
(0018166)
vins_14 (reporter)
2013-01-15 18:36

Here are the top 5 tables (based on the row size):
table_name,table_rows,DATA_LENGTH,INDEX_LENGTH,MAX_DATA_LENGTH
events,71603,7947292,2214912,281474976710655
nodes_hierarchy,42945,1433568,1656832,281474976710655
tcsteps,26157,95287504,336896,281474976710655
executions,16930,940764,623616,281474976710655
user_assignments,15053,617173,400384,11540474045136895
cfield_design_values,11793,331892,362496,281474976710655
testplan_tcversions,8966,288052,342016,8725724278030335
tcversions,8957,50221376,121856,281474976710655
transactions,7862,3015276,296960,281474976710655
testcase_keywords,2470,22230,44032,2533274790395903

are this tables generated using copy & paste from word ?
I am able to reproduce the issue using copy/paste from excel and using the table generation functionality that comes with TestLink.

is you create an empty test case this also happens ?
If I create a test case with just test or limited amount of data in those fields, I do not have any issues, the same gets created successfully.
(0018169)
fman (administrator)
2013-01-15 21:22

do not think I've a solution but the size of TEXT TABLES (not db tables) that you are trying to create on the test case can be in part the reason.
Without anyway to reproduce it is very difficult to find a solution
(0018172)
vins_14 (reporter)
2013-01-15 23:50

The issue was caused due to the escaping of the ampersand character. To fix the issue, please upgrade the FCKeditor (we have to upgrade from 2.6.6 to 2.6.9) and that seems to have fixed the same.
(0018177)
fman (administrator)
2013-01-16 16:36

upgrade third party sw

- Issue History
Date Modified Username Field Change
2013-01-15 00:36 vins_14 New Issue
2013-01-15 18:36 vins_14 Note Added: 0018166
2013-01-15 21:22 fman Note Added: 0018169
2013-01-15 23:50 vins_14 Note Added: 0018172
2013-01-16 16:36 fman Note Added: 0018177
2013-01-16 16:36 fman Status new => resolved
2013-01-16 16:36 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2013-01-16 16:36 fman Resolution open => fixed
2013-01-16 16:36 fman Assigned To => fman
2013-05-30 19:41 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker