Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005468TestLinkExport/Importpublic2013-01-14 07:222013-05-30 19:41
Reporterthomas.peters.al 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformApache2OSServer-Ubuntu, Client-WindowsOS Version10.04LTS-XP Prof
Product Version1.9.5 (2012 Q4 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005468: TC with same ID after import within one project
DescriptionAfter creating a project from an existing one the testcases in the new project have been altered. Now they shall be imported in the old project again as new version of the testcases. As in both projects new testcases had been created the new testcases from the new project are also inserted into the old one. This leads to testcases with the same ID within one project.
Steps To Reproduce1. Create a project with some Testcases
2. Create a new project by copying it from the old one ("Create from existing project"=<old_project_name>
3. Alter the testcases in the new project
4. Create at least one new testcase in each of the projects and check that they have the same ID (external ID?) related to their project
5. Export (one suite from) the new project
6. Import the (suite from) new project into the old one. (FileType=XML, <exported_xml_file>, ConsiderAsDupIf=HasSameName, Action=CreateNewVersion)
7. Check if both new testcases are in the old project. They'll most probably have the same ID. At least they had in my case.
Additional InformationI don't have a good solution for this problem in mind yet but I don't think it is good to have two testcases with the same ID in one project.

I have attached a screenshot and will attach eample xml files.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox 18.0
PHP VersionPHP 5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon doubleID.jpg [^] (66,861 bytes) 2013-01-14 07:22


xml file icon DoubleIDTest.testproject-deep.xml [^] (1,655 bytes) 2013-01-14 07:22
xml file icon OhneVision.testproject-deep.xml [^] (1,640 bytes) 2013-01-14 07:23
xml file icon OhneVision.finish.xml [^] (2,004 bytes) 2013-01-14 07:23

- Relationships
duplicate of 0005309closedfman Test case summary and Test case ID getting duplicated->import the Test specification XML file inside subtree 

-  Notes
(0018154)
thomas.peters.al (reporter)
2013-01-14 07:25

OhneVision.testproject-deep.xml is the old project with one new testcase.
DoubleIDTest.testproject-deep.xml it the new project already with one testcase.
OhneVision.finish.xml is the old project after importing the new one. So the one with 2 times the same ID.

- Issue History
Date Modified Username Field Change
2013-01-14 07:22 thomas.peters.al New Issue
2013-01-14 07:22 thomas.peters.al File Added: doubleID.jpg
2013-01-14 07:22 thomas.peters.al File Added: DoubleIDTest.testproject-deep.xml
2013-01-14 07:23 thomas.peters.al File Added: OhneVision.testproject-deep.xml
2013-01-14 07:23 thomas.peters.al File Added: OhneVision.finish.xml
2013-01-14 07:25 thomas.peters.al Note Added: 0018154
2013-01-14 10:46 fman Task Workflow Status TBD => READY FOR TESTING
2013-01-14 10:46 fman Status new => resolved
2013-01-14 10:46 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2013-01-14 10:46 fman Resolution open => fixed
2013-01-14 10:46 fman Assigned To => fman
2013-01-14 10:51 fman Relationship added duplicate of 0005309
2013-05-30 19:41 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker