Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005462TestLinkTest Specificationpublic2013-01-11 19:312013-05-30 19:40
Reporterbiswasdi 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.5 (2012 Q4 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005462: Clicking on "Apply Filters" button by selecting a Top Suite in Test Specifications dumps underlying code into the Filters frame.
DescriptionIn the Test Specification tab, if we try to Apply filters on any existing Top Level Suite, the page is rendering unwanted code information. The functionality is broken. For more details, please refer to the attached image.

However, I did find that this functionality works fine in TL 1.9.6, which is not yet released. Can you please provide us with a fix, maybe a particular file that needs replacement with a newer version?

I was able to reproduce the error in all browsers.
Steps To ReproduceNavigate to 'Test Specification' tab.
In the Filters section, select any existing top level Test Suite.
Click on Apply filters button.
The page renders some underlying code in the frame as shown in the attached image.
Additional InformationI have verified that this functionality is working fine in the latest code available for TL 1.9.6, which is not yet released.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserIE9, Firefox, Chrome
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon TL_TestSpec_FilterSelect.jpg [^] (104,474 bytes) 2013-01-11 19:31


jpg file icon TL_TestSpec_FilterError.jpg [^] (171,432 bytes) 2013-01-11 19:32

- Relationships
duplicate of 0005432closedfman Debug output when filtering on test specification page 
child of 0005406closedfman Availables hot-fixes for 1.9.5 & How To get full fixed package from gitorious 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2013-01-11 19:31 biswasdi New Issue
2013-01-11 19:31 biswasdi File Added: TL_TestSpec_FilterSelect.jpg
2013-01-11 19:32 biswasdi File Added: TL_TestSpec_FilterError.jpg
2013-01-11 22:04 fman Task Workflow Status TBD => READY FOR TESTING
2013-01-11 22:04 fman Relationship added duplicate of 0005432
2013-01-11 22:04 fman Status new => resolved
2013-01-11 22:04 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2013-01-11 22:04 fman Resolution open => fixed
2013-01-11 22:04 fman Assigned To => fman
2013-01-11 22:04 fman Relationship added child of 0005406
2013-05-30 19:40 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker