Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005449TestLinkBug Tracking System - Bugzilla Integrationpublic2013-01-03 16:202013-05-26 18:52
ReporterJulienBreton 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS VersionSeven
Product Version1.9.5 (2012 Q4 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005449: [Bugzilla] Bugs closed, verified, resolved not counted in correct way on report Bugs for Test Case
DescriptionI use Bugzilla interface db.

-In Testlink when I add a bug I see the bug's statut (NEW, ASSIGNED, VERIFIED...) but a bug with the status ASSIGNED is not striked.
-In the report "Bugs per Test Case" the bug are not consider as "Resolved".
Steps To Reproduce-In Bugzilla creat a new bug.
-In Testlink, when you execute a test case, add this bug.
-In Bugzilla pass the bug to VERIFIED
=>In the test execution page the bug are not stricked.
-Go on the report "Bugs per Test Case". The bug are not count as "Resolved".

Additional InformationI think is similar to the bug 5401.
I think the bug (if it's a bug) is in the function "buildStatusHTMLString" in the file "bugzilladbInterface.class.php" because "$status" is always NULL.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox 17.0.1
PHP Version5.4.3
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon Capture_1.jpg [^] (135,592 bytes) 2013-01-03 16:20


jpg file icon Capture_2.jpg [^] (122,098 bytes) 2013-01-03 16:20

- Relationships
duplicate of 0005401closedfman Closed redmine issues are not considered Resolved in TestLink 
child of 0005406closedfman Availables hot-fixes for 1.9.5 & How To get full fixed package from gitorious 

-  Notes
(0018116)
fman (administrator)
2013-01-03 20:26

on issue 0005417 we have declared the issue as known => this issue is a duplicate.
(0018120)
fman (administrator)
2013-01-05 15:46

http://gitorious.org/testlink-ga/testlink-code/commit/fce47bd66b8a26d86c907724f5f097fd39186efb [^]

- Issue History
Date Modified Username Field Change
2013-01-03 16:20 JulienBreton New Issue
2013-01-03 16:20 JulienBreton File Added: Capture_1.jpg
2013-01-03 16:20 JulienBreton File Added: Capture_2.jpg
2013-01-03 20:25 fman Relationship added duplicate of 0005401
2013-01-03 20:26 fman Note Added: 0018116
2013-01-05 13:44 fman Summary [Bugzilla] Bugs closed, verified, resolded not stricked => [Bugzilla] Bugs closed, verified, resolved not counted in correct way on report Bugs for Test Case
2013-01-05 15:46 fman Task Workflow Status TBD => READY FOR TESTING
2013-01-05 15:46 fman Note Added: 0018120
2013-01-05 15:46 fman Status new => resolved
2013-01-05 15:46 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2013-01-05 15:46 fman Resolution open => fixed
2013-01-05 15:46 fman Assigned To => fman
2013-01-05 15:46 fman Relationship added child of 0005406
2013-05-26 18:52 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker