Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005441TestLinkRequirements Import - TL XML formatpublic2012-12-26 22:002013-05-26 18:52
Reporterfrl 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWAMPOSWindowsOS VersionSeven
Product Version1.9.5 (2012 Q4 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005441: Could not update requirement with XML import
DescriptionWhen I try to import requirements from an XML file to update existing reqs, an error msg is displayed


Test 1 :
#######
Create a new project (no requirement defined yet)

Import twice the same file for reqs (from project's root node)
- 1st import => OK (1 req spec + 3 reqs created)
- 2nd import => KO (see pbm import req.png)

Options used for import was:
Skip frozen requirements (no)
Consider Requirement as duplicate if (has same DOC ID)
Action for duplicates (Update data on Latest version)


Test 2 :
#######
Delete the req spec TM-RDD (with its 3 reqs) => KO (the record for the TM-RDD corresponding to req_specs_revisions was not deleted in node_hierarchy table whereas req_specs_revisions is empty)

Test 3 :
#######

Recreate a new project (no requirement defined yet)

Import twice the same file for reqs (from project's root node)
- 1st import => OK (1 req spec + 3 reqs created)
- 2nd import => KO (see pbm import req2.png)
 
Options used for import was:
Skip frozen requirements (no)
Consider Requirement as duplicate if (has same DOC ID)
Action for duplicates (Create new version)
Steps To ReproduceSee description using attached file for import
Additional InformationInfos found in logs file

[>>][50db68b07ba0d979315594][DEFAULT][/tl195-mogl/lib/requirements/reqImport.php][12/Dec/26 21:14:24]

    [12/Dec/26 21:14:24][ERROR][sq4lkslga47jlq4hcdp3nkolg0][DATABASE]

        ERROR ON exec_query() - database.class.php
1064 - Erreur de syntaxe près de '' à la ligne 1 - /* Class:requirement_mgr - Method: update */ UPDATE req_versions SET scope='\n

La gestion des tests doit supporter le constitution d\'un référentiel de tests projet

\n', status='F', expected_coverage=0, type='2' , modifier_id=1, modification_ts='2012-12-26 22:14:24' WHERE id=
THE MESSAGE : /* Class:requirement_mgr - Method: update */ UPDATE req_versions SET scope='\n

La gestion des tests doit supporter le constitution d\'un référentiel de tests projet

\n', status='F', expected_coverage=0, type='2' , modifier_id=1, modification_ts='2012-12-26 22:14:24' WHERE id=

Query failed: errorcode[1064]
    errormsg:Erreur de syntaxe près de la ligne 1
 
    [12/Dec/26 21:14:24][WARNING][sq4lkslga47jlq4hcdp3nkolg0][GUI]

        E_NOTICE

Undefined property: database::$error_msg - in D:\EasyPHP-5.3.8.1\www\testlink-1.9.5\lib\functions\requirement_mgr.class.php - Line 458

TagsNo tags attached.
Database (MySQL,Postgres,etc)mySQL 5.1
BrowserIE9
PHP Version5.3.8
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesxml file icon TL195-import-reqs-nocf.xml [^] (1,690 bytes) 2012-12-26 22:00
png file icon pbm import req.png [^] (41,484 bytes) 2012-12-26 22:01


png file icon pbm import req 2.png [^] (75,151 bytes) 2012-12-26 22:02

- Relationships
related to 0005442closedfman Deleting a req spec, leaves record on nodes hierachy regarding req spec revision 
child of 0005406closedfman Availables hot-fixes for 1.9.5 & How To get full fixed package from gitorious 

-  Notes
(0018100)
fman (administrator)
2012-12-27 18:01

1.9.5
http://gitorious.org/testlink-ga/testlink-code/commit/021afc8fbae81ff1cd57e165c182feecf93ce196 [^]

You can get the file pointing to:
http://gitorious.org/testlink-ga/testlink-code/blobs/testlink_1_9/lib/functions/requirement_mgr.class.php [^]

and then using the 'Raw blob data' button ( you will need to rename the file)

please provide feedback
(0018101)
frl (reporter)
2012-12-27 23:11

I did more tests with this fixed version :

tests 1 & 3 are now OK (requirements are well updated with expected result in both cases)

N.B. test 2 still fails (deletion of a req spec do not remove the related req_spec_revision entry in node_hierarchy table). But I did not detect any functional impact => may be another minor issue.

Thanks
(0018102)
fman (administrator)
2012-12-28 09:35

OK, I will open a new issue, because from start Test Case 2 was MISPLACED, because this issue is about XML import not req spec delete.
The standard guidelines for issue reporting always said: do not mix several issue on one ticket.

- Issue History
Date Modified Username Field Change
2012-12-26 22:00 frl New Issue
2012-12-26 22:00 frl File Added: TL195-import-reqs-nocf.xml
2012-12-26 22:01 frl File Added: pbm import req.png
2012-12-26 22:02 frl File Added: pbm import req 2.png
2012-12-27 17:36 fman Assigned To => fman
2012-12-27 17:36 fman Status new => assigned
2012-12-27 18:01 fman Note Added: 0018100
2012-12-27 18:02 fman Relationship added child of 0005406
2012-12-27 19:27 fman Status assigned => feedback
2012-12-27 23:11 frl Note Added: 0018101
2012-12-27 23:11 frl Status feedback => assigned
2012-12-28 09:35 fman Note Added: 0018102
2012-12-28 10:54 fman Relationship added related to 0005442
2012-12-28 14:10 fman Task Workflow Status TBD => READY FOR TESTING
2012-12-28 14:10 fman Status assigned => resolved
2012-12-28 14:10 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2012-12-28 14:10 fman Resolution open => fixed
2013-05-26 18:52 fman Status resolved => closed
2013-11-24 18:50 fman Category Import Requirements - XML format => Requirements Import - TL XML format



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker