Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005414TestLinkReportspublic2012-12-11 10:102013-05-26 18:52
Reportermbar 
Assigned Tofman 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.5 (2012 Q4 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005414: Direct link without login -- apikey parameter is missing for Redmine
DescriptionWhen I try to use new functionality (direct link without login) then I always get the following error:

Input name: apikey :: Exception Input parameter validation failed [minLen - target: 32 - actual: 0]

This is caused by missing "apikey" parameter value. apikey for Redmine is configured OK on our suystem.
When I copy the apikey from the config file (32 hex characters) and paste it into http link, then the direct link without login functionality works OK.
Please see screenshots.
Steps To ReproduceHave TestLink with Redmine rest interface configured, with valid apikey.
Try to use direct link without login -- it will fail due to missing apikey value on the http address line in the browser.
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon dire01.png [^] (17,107 bytes) 2012-12-11 10:10


png file icon dire02.png [^] (18,435 bytes) 2012-12-11 10:10


png file icon dire03.png [^] (24,082 bytes) 2012-12-11 10:10

- Relationships
child of 0005406closedfman Availables hot-fixes for 1.9.5 & How To get full fixed package from gitorious 

-  Notes
(0018020)
fman (administrator)
2012-12-11 10:52

You have misunderstood the apikey. THIS IS THE TESTLINK apikey that EACH USER have.
You have to enable TL API.
Give a look to forum for info about this.
Then EACH USER WILL be able to generate the APIKEY


I'm going to add a check when the key is missing
(0018022)
mbar (reporter)
2012-12-11 11:08

Ah, OK then, disregard :)
A check would be useful on the other hand.
(0018027)
fman (administrator)
2012-12-11 21:46

commit
http://gitorious.org/testlink-ga/testlink-code/commit/0b9a44675464b7f92d98799c9cb5d106b715c201 [^]

- Issue History
Date Modified Username Field Change
2012-12-11 10:10 mbar New Issue
2012-12-11 10:10 mbar File Added: dire01.png
2012-12-11 10:10 mbar File Added: dire02.png
2012-12-11 10:10 mbar File Added: dire03.png
2012-12-11 10:52 fman Note Added: 0018020
2012-12-11 10:54 fman Category Bug Tracking System - Redmine Integration => Reports
2012-12-11 11:08 mbar Note Added: 0018022
2012-12-11 21:46 fman Note Added: 0018027
2012-12-11 21:47 fman Tag Attached: TO BE FIXED on 2.0
2012-12-11 21:47 fman Relationship added child of 0005406
2012-12-11 21:47 fman Task Workflow Status TBD => READY FOR TESTING
2012-12-11 21:47 fman Status new => resolved
2012-12-11 21:47 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2012-12-11 21:47 fman Resolution open => fixed
2012-12-11 21:47 fman Assigned To => fman
2013-05-26 18:52 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker