Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005403TestLinkRequirement Managementpublic2012-12-07 12:482013-05-26 18:52
Reporterfrl 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLAMPOSDebianOS Version6.0
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.5 (2012 Q4 - bug fixing) 
Summary0005403: method requirement_spec_mgr->get_by_title() causes a DB access error
DescriptionIt tried to use requirement_spec_mgr->get_by_title() to retrieve a req spec ID with its title.
I got an error 0001054 - Unknown column 'RSPEC' in 'field list'
with the following debug trace info
#1 database->fetchRowsIntoMap(/* Class:requirement_spec_mgr - Method: get_by_title */ SELECT RSPEC.id,testproject_id,RSPEC,doc_id,RSPEC.scope,RSPEC.total_req,RSPEC.type, RSPEC.author_id,RSPEC.creation_ts,RSPEC.modifier_id, RSPEC.modification_ts,NH.name AS title FROM req_specs RSPEC, nodes_hierarchy NH WHERE NH.name='TM-SODD' AND RSPEC.id=NH.id AND RSPEC.testproject_id=139 AND RSPEC.id=NH.id , id) called at [C:\Program Files\EasyPHP-5.3.6.1\www\testlink-1.9.3\lib\functions\requirement_spec_mgr.class.php:710]
0000002 requirement_spec_mgr->get_by_title(TM-SODD, 139) called at [C:\Program Files\EasyPHP-5.3.6.1\www\testlink-1.9.3\lib\api\extended_server.php:142]
...
Additional InformationSeems there is a syntax error in SQL query string : RSPEC,doc_id should be RSPEC.doc_id

I did not test with 1.9.4, but I also found this syntax error in 1.9.4 code (original published release).
N.B. this method seems not updated to support req_specs_revisions table in 1.9.4. Is it deprecated ?
TagsNo tags attached.
Database (MySQL,Postgres,etc)mySQL 5.1
BrowserN/A
PHP Version5.3
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships

-  Notes
(0017997)
fman (administrator)
2012-12-07 18:04

>> N.B. this method seems not updated to support
>> req_specs_revisions table in 1.9.4. Is it deprecated ?
This method is intended to get by NAME TAKING IN CONSIDERATION
LATEST REVISION, that's why name is searched on Nodes Hierarchy table.

for TL 'THE REQUIREMENT' is always the latest revision.
Other revisions can not be used in anyway through user interface

In some sort the same applies to requirements WE DO NOT USE REQ VERSION OR REVISIONS to link req to test cases, we always USE LATEST VERSION+REVISION

- Issue History
Date Modified Username Field Change
2012-12-07 12:48 frl New Issue
2012-12-07 18:04 fman Note Added: 0017997
2012-12-07 18:04 fman Task Workflow Status TBD => READY FOR TESTING
2012-12-07 18:04 fman Status new => resolved
2012-12-07 18:04 fman Fixed in Version => 1.9.5 (2012 Q4 - bug fixing)
2012-12-07 18:04 fman Resolution open => fixed
2012-12-07 18:04 fman Assigned To => fman
2013-05-26 18:52 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker