Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005401TestLinkReportspublic2012-12-07 09:302013-05-30 19:40
Reportermbar 
Assigned Tofman 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005401: Closed redmine issues are not considered Resolved in TestLink
DescriptionThis happened lately, like within last 2 weeks. I'm using latest 1.9.4 QA code from git (5193 issue) downloaded on 03.12.2012. Today I noticed that bug reports in Redmine that are set to Closed are no longer considered Resolved by TestLink. Please see screenshot.

That report was OK in November.
Steps To ReproduceBugs per Test Case report, one has to have some TCs with connected redmine issues with status Closed.
Tagsreport by tester per build
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon tl_bugs_per_tc.png [^] (36,411 bytes) 2012-12-07 09:30


png file icon tl_bugs_per_tc2.png [^] (51,031 bytes) 2012-12-10 09:49


png file icon issue-5401.png [^] (34,451 bytes) 2012-12-10 19:29


png file icon tl_bugs_per_tc3.png [^] (46,245 bytes) 2012-12-11 08:30

- Relationships
has duplicate 0005449closedfman [Bugzilla] Bugs closed, verified, resolved not counted in correct way on report Bugs for Test Case 
related to 0005417closedfman Closed/Resolved issues are not considered Resolved AND THEN NOT COUNTED in TestLink 
child of 0005406closedfman Availables hot-fixes for 1.9.5 & How To get full fixed package from gitorious 

-  Notes
(0017986)
fman (administrator)
2012-12-07 09:55

In order to consider the isseu we need a complete textual description of steps, with expected results and actual results, i.e. a complete test case.
(0017988)
mbar (reporter)
2012-12-07 10:11

I will cut to the chase here: let's say we already have a test project, test suite with test cases. Also let's assume we have a test plan with added test cases ready to execute.
- on test case execution page add new bug report, use Redmine tracker with rest interface (enter Redmine ID of an existing Redmine issue). The redmine issue can be in "New" status
- save test case execution
- go to Bugs per Test Case report, see that the Redmine issue is connected to your saved test case, and note that TestLink considers it as Open (all is OK here: New is kinda Open)
- change Redmine issue status to Closed
- go to Bugs per Test Case report, see that the Redmine issue is connected to your saved test case, and note that TestLink STILL considers it as Open (wrongly), even if the real status is shown as [Closed]

Expected result: TestLink should consider Closed Redmine issue as Resolved and print it with strikeout font on the Bugs per Test Case report. It did that before :)
(0017992)
fman (administrator)
2012-12-07 14:28

Ok, a lot better.
I'm going to give a look and then provide here the exact model of how we need issues will be reported
(0017998)
fman (administrator)
2012-12-07 18:09

if all the issue is the strikeout font , then IMHO this is not an really issue
because we can change the way we use to represent on video different status.
May be the strikeout font was original author choice, but this does not means we will support this, Not matter what have done before.
I will consider this an issue if report is presenting WRONG DATA , from
the figures point of view.

Please provide feedback.
You can think about an option to choose how to display resolved issue at GUI LEVEL
(0018007)
mbar (reporter)
2012-12-10 09:49

I agreee that "strikeout" font is not an issue here.
The real issue is wrong count of Open/Resolved bugs in Bugs per test Case report in Test Link on data from Redmine interface.
Please see new tl_bugs_per_tc2.png screenshots with red highlights.
(0018008)
fman (administrator)
2012-12-10 11:11

OK, got the idea and found the issue
Original implementation use this code
if ((!strpos($bugInfo['link_to_bts'],"<del>")) && 
    (!strpos($bugInfo['link_to_bts'],"</del>")))


To identify issue status, and IMHO This SUCKS because there is NO CLEAR
indication on dev docs of THIS.

I'm going to try to find a better solution.

You will be informed AUTOMATICALLY by mantis, when work will be done on this issue.

Thanks for your help
(0018009)
mbar (reporter)
2012-12-10 11:25

Thanks!
Today we migrated to latest 1.9.5 QA, i.e. TestLink Development Prague 1.9.6 (Q1 2013), so you can update Product Version of this issue if it's better for you.
(0018010)
mbar (reporter)
2012-12-10 11:27

Product version should be "1.9.5 (2012 Q4 - bug fixing)" but I cannot change it.
(0018013)
fman (administrator)
2012-12-10 19:17

Try with latest commit (use instructions provided on 0005406 ), and provide feedback
(0018016)
Thayalan (reporter)
2012-12-11 06:57

I downloaded and deployed. But When I tried to link a failed Test cases with an existing mantis defect. It's not getting added properly. Build Column updated but 'Relevant bugs' column is blank. Please confirm whether I'm missing anything here.
(0018017)
mbar (reporter)
2012-12-11 08:29

Latest commit works OK for Redmine :) Consider this case solved.
Thanks a lot!
(0018019)
fman (administrator)
2012-12-11 10:48

@thayalan
For mantis db this has not been implemented yet
only for mantis soap and redmine rest
(0018023)
Thayalan (reporter)
2012-12-11 12:06

Thanks fman. You info shed light on the issue I faced with earlier.

- Issue History
Date Modified Username Field Change
2012-12-07 09:30 mbar New Issue
2012-12-07 09:30 mbar File Added: tl_bugs_per_tc.png
2012-12-07 09:54 fman Priority high => low
2012-12-07 09:54 fman Description Updated View Revisions
2012-12-07 09:55 fman Note Added: 0017986
2012-12-07 09:56 fman Status new => feedback
2012-12-07 10:11 mbar Note Added: 0017988
2012-12-07 10:11 mbar Status feedback => new
2012-12-07 14:28 fman Note Added: 0017992
2012-12-07 18:09 fman Note Added: 0017998
2012-12-07 18:10 fman Status new => feedback
2012-12-09 17:20 fman Status feedback => closed
2012-12-09 17:20 fman Assigned To => fman
2012-12-09 17:20 fman Resolution open => won't fix
2012-12-10 09:49 mbar Note Added: 0018007
2012-12-10 09:49 mbar Status closed => assigned
2012-12-10 09:49 mbar Resolution won't fix => reopened
2012-12-10 09:49 mbar File Added: tl_bugs_per_tc2.png
2012-12-10 11:11 fman Note Added: 0018008
2012-12-10 11:25 mbar Note Added: 0018009
2012-12-10 11:27 mbar Note Added: 0018010
2012-12-10 19:17 fman Note Added: 0018013
2012-12-10 19:17 fman Relationship added child of 0005406
2012-12-10 19:17 fman Status assigned => feedback
2012-12-10 19:29 fman File Added: issue-5401.png
2012-12-11 06:57 Thayalan Note Added: 0018016
2012-12-11 08:29 mbar Note Added: 0018017
2012-12-11 08:29 mbar Status feedback => assigned
2012-12-11 08:30 mbar File Added: tl_bugs_per_tc3.png
2012-12-11 10:48 fman Note Added: 0018019
2012-12-11 12:06 Thayalan Note Added: 0018023
2012-12-12 07:02 fman Issue cloned: 0005417
2012-12-12 07:02 fman Relationship added related to 0005417
2012-12-12 07:04 fman Task Workflow Status TBD => READY FOR TESTING
2012-12-12 07:04 fman Status assigned => resolved
2012-12-12 07:04 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2012-12-12 07:04 fman Resolution reopened => fixed
2013-01-03 20:25 fman Relationship added has duplicate 0005449
2013-01-07 21:50 aostad Tag Attached: report by tester per build
2013-05-30 19:40 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker