Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005379TestLinkReportspublic2012-11-30 15:222013-05-30 19:40
Reporterzdenek.juran 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSCentOSOS Version5.4
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version1.9.5 (2012 Q4 - bug fixing) 
Summary0005379: Metric is not count when Postgres database is used
DescriptionThe SQL error is reported during generating Test Report with Metric when PostgreSQL 8.1.18 database is used as
Steps To ReproduceGenerate Test Report with Metric with PostgreSQL 8.1.18 database in background
Additional InformationPatch is attached
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres
BrowserN/A
PHP Version5.2.13
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespatch file icon tlTestPlanMetrics.class.php.patch [^] (515 bytes) 2012-11-30 15:22 [Show Content]
? file icon tlTestPlanMetrics.class.php [^] (80,947 bytes) 2012-11-30 16:16

- Relationships

-  Notes
(0017940)
fman (administrator)
2012-11-30 15:48

please ALWAYS provide detailed steps to reproduce in addition to fix.
Without details we can not create the regression test
Please provide always full code not patches because are more difficult to use for not developers (this is our standard way to procede)
(0017941)
zdenek.juran (reporter)
2012-11-30 16:15

Steps to reproduce:
0) Install TestLink and configure with PostgreSQL backend
1) Generate test plan with time tracking fields, you can turn on platforms (optional)
2) Generate hierarchy of test suites and test cases with time estimation
3) Assign test cases to the new test plan
4) Generate build for test plan
5) go to reports - Test Report
6) Check "Metric" option
7) Click on the top of the test project hierarchy
(0017942)
zdenek.juran (reporter)
2012-11-30 16:16

Full code attached
(0017944)
fman (administrator)
2012-11-30 18:45

OK thanks, we will give a look

- Issue History
Date Modified Username Field Change
2012-11-30 15:22 zdenek.juran New Issue
2012-11-30 15:22 zdenek.juran File Added: tlTestPlanMetrics.class.php.patch
2012-11-30 15:48 fman Note Added: 0017940
2012-11-30 16:15 zdenek.juran Note Added: 0017941
2012-11-30 16:16 zdenek.juran File Added: tlTestPlanMetrics.class.php
2012-11-30 16:16 zdenek.juran Note Added: 0017942
2012-11-30 18:45 fman Note Added: 0017944
2012-11-30 21:15 fman Task Workflow Status TBD => READY FOR TESTING
2012-11-30 21:15 fman Status new => resolved
2012-11-30 21:15 fman Fixed in Version => 1.9.5 (2012 Q4 - bug fixing)
2012-11-30 21:15 fman Resolution open => fixed
2012-11-30 21:15 fman Assigned To => fman
2013-05-30 19:40 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker