Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005372TestLinkTest Plan - Add/Remove Test Casespublic2012-11-27 07:322016-03-28 09:25
Reporterrosacoco 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWindows 7 x64OS Version
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version1.9.5 (2012 Q4 - bug fixing) 
Summary0005372: Add 400 test cases to test plan at one time, only 242 cases are added
DescriptionAdd 400 (or more) test cases to test plan at one time, only 242 cases are added
Steps To Reproduce1. import a test suite with 400 test cases
2. In the Add/Remove test cases to test plan pane, select the top test suite to show all 400 test cases at right pane.
3. check all for adding and click the add/remove selected button
see only first 242 cases are added,
in plan/planAddTC.php, line 66, $args->testcases2add size is 242.

4. then on the right pane which contains 400 test cases, manually check the add check box of the remaining test cases
5. click Add/Remove selected button, the remaining cases are NOT added.
in plan/planAddTC.php, line 66 $args->testcases2add is null

6. select sub test suite which only contain 20 not added test case, check for add all test cases and click add/remove selected test cases, this time the 20 cases would be added to test plan.
Additional Informationset in php.ini
memory_limit=512M
max_execution_time = 12000
TagsNo tags attached.
Database (MySQL,Postgres,etc)mysql
Browser
PHP Version5.3.14
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filesxml file icon Test suite B.xml [^] (189,664 bytes) 2012-11-29 08:26
jpg file icon Fatal.jpg [^] (136,304 bytes) 2012-11-29 08:42


jpg file icon Service_unavailable.jpg [^] (74,676 bytes) 2012-11-30 04:43

- Relationships
has duplicate 0004340closedfman I am not able add test cases to test plan which already contains 448 test cases. 
has duplicate 0005522closedfman DB access error by adding more than 200 test cases to test plan 
has duplicate 0005915closedfman Get DB Access Error when trying to add test cases 
has duplicate 0005953closedfman Testcase import is limited to 233 or less 
related to 0007484closedfman Not able to add all the required test cases to the test plan. 
child of 0005193closedfman Availables hot-fixes for 1.9.4 & How To get full fixed package from gitorious 

-  Notes
(0017915)
rosacoco (reporter)
2012-11-27 07:38

The problem is: you can't add the cases after number 242, if the right pane of add/remove test cases contains 400 cases. even by manually check the add check box and click add.

More info: The test suite with 400 test cases contains 20 test suites, each of the test suites contains 20 test cases.
(0017917)
fman (administrator)
2012-11-27 19:19

provide xml with test case in order to try to reproduce
(0017929)
sujataverma3 (reporter)
2012-11-29 08:38

I could reproduce the issue, steps are:

1) Create Test Project A, Test Plan A, Build A, five Platforms ->A, B, C, D,E

2) Test Specification -> import the attached xml file ( it has 404 test cases, generated from testlink demo testcases)

3) Add all the platforms

4) Go to Add/Remove test cases-> try to add and assign to admin -> all testcases for all platforms->

Fatal error is displayed and only 242 tc per platform are added,

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2640 bytes) in C:\xampp\htdocs\testlink24nov\testlink\third_party\adodb\adodb.inc.php on line 187

5) Try to remove the added test cases following error is displayed.


"Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 408 bytes) in C:\xampp\htdocs\testlink24nov\testlink\third_party\adodb\drivers\adodb-mysql.inc.php on line 1087"
(0017930)
sujataverma3 (reporter)
2012-11-29 08:45

The code used to test this was released on Nov 24, downloaded from

https://docs.google.com/open?id=0B-hNfKQRC5a5M0FtYjBLSUIwNjQ [^]

In above the count which was displayed was 224 as in attached screenshot.
(0017931)
fman (administrator)
2012-11-29 09:53

@sujataverma
Thanks a lot, great work as usual
(0017933)
fman (administrator)
2012-11-29 21:37
edited on: 2012-11-29 21:43

=========================================================================
Environment - ALL LOCAL => have mysql running on same host that apache
IBM Z60 - 2G RAM - Running Fedora 14 - LAMPP - Firefox 17
=========================================================================

TC-01
1. Create Test project
2. import provided XML => 1 TEST SUITE 404 TEST CASES
3. Create a test plan
4. add all test cases
ALL OK

TC-02
Always same test project
create new test plan
ADD 5 platforms
ALL Ok

(0017935)
sujataverma3 (reporter)
2012-11-30 04:41

This is what i got when i did, same steps in demo server.

=============================
Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

=============================

Please see in events, and in demo server for project : Bug 5372
(0018036)
fman (administrator)
2012-12-12 22:13

IMHO there is some issue with POST SIZE, that's why we do not get all selected test cases.
Unfortunately on my installation I'm not able to reproduce (LAMPP).
Need some help from you
(0018050)
fman (administrator)
2012-12-14 06:51

Is not TL issue but PHP setting:
See http://www.teamst.org/forum/viewtopic.php?f=11&t=7124&p=17274&sid=b8f2d6a7d49c9a9351c4cd895f2333ae#p17274 [^]

SOLVED WITH:
In php.ini I changed max_input_vars = 1000 to max_input_vars = 10000


Read:
http://stackoverflow.com/questions/9496 [^] ... checkboxes
http://stackoverflow.com/questions/1038 [^] ... new-server


ATTENTION check if this settings work with your PHP VERSION (seems to need > 5.3.9)
(0018064)
fman (administrator)
2012-12-14 19:34

see related issu for solution
(0018065)
fman (administrator)
2012-12-14 19:34

NOT a TL ISSUE, config issue
(0018342)
rosacoco (reporter)
2013-02-18 03:59

Tried the fix and it works!
Thank you very much.

- Issue History
Date Modified Username Field Change
2012-11-27 07:32 rosacoco New Issue
2012-11-27 07:38 rosacoco Note Added: 0017915
2012-11-27 19:19 fman Note Added: 0017917
2012-11-29 08:26 sujataverma3 File Added: Test suite B.xml
2012-11-29 08:38 sujataverma3 Note Added: 0017929
2012-11-29 08:42 sujataverma3 File Added: Fatal.jpg
2012-11-29 08:45 sujataverma3 Note Added: 0017930
2012-11-29 09:53 fman Note Added: 0017931
2012-11-29 21:37 fman Note Added: 0017933
2012-11-29 21:43 fman Note Edited: 0017933 View Revisions
2012-11-30 04:41 sujataverma3 Note Added: 0017935
2012-11-30 04:43 sujataverma3 File Added: Service_unavailable.jpg
2012-12-12 22:13 fman Note Added: 0018036
2012-12-14 06:51 fman Note Added: 0018050
2012-12-14 06:51 fman Assigned To => fman
2012-12-14 06:51 fman Status new => feedback
2012-12-14 06:54 fman Relationship added has duplicate 0004340
2012-12-14 19:34 fman Note Added: 0018064
2012-12-14 19:34 fman Note Added: 0018065
2012-12-14 19:34 fman Status feedback => resolved
2012-12-14 19:34 fman Resolution open => fixed
2013-02-09 16:24 fman Relationship added has duplicate 0005522
2013-02-09 16:25 fman Fixed in Version => 1.9.5 (2012 Q4 - bug fixing)
2013-02-09 16:26 fman Relationship added child of 0005193
2013-02-18 03:59 rosacoco Note Added: 0018342
2013-05-26 18:50 fman Status resolved => closed
2013-09-13 09:54 fman Relationship added has duplicate 0005915
2013-10-05 16:41 fman Relationship added has duplicate 0005953
2016-03-28 09:25 fman Relationship added related to 0007484



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker