Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005359TestLinkUser Interface Generalpublic2012-11-21 16:082013-05-30 19:42
Reportermcosorio 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS VersionXP SP3
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version1.9.5 (2012 Q4 - bug fixing) 
Summary0005359: FCKEditor doesn't load in Firefox 17
DescriptionI've upgrade Firefox to version 17 and the FCKEditor stopped loading. Instead of the editor, Testlink shows a textarea.

I've seen the bug in Windows XP with a fresh install of Firefox (no plugins and no extensions).

We have other applications that use FKCEditor, but the editor is working fine in all apps on Firefox 17.
Steps To ReproduceThe bug appears wherever there's an editor, including the following screens (but may not be limited to):

- Test Specification
-- Create/Edit test suite screen: "Details" field
-- Create/Edit test case: "Summary" and "Preconditions" fields
-- Create test case step: "Step actions" and "Expected Results"

- Requirement Specification: "Scope" field

- Project description
- Build description
Additional InformationAfter upgrading Firefox to 17, I downgraded it to 16 and everything was ok.
In IE8 there's no problem, too.
TagsNo tags attached.
Database (MySQL,Postgres,etc)Postgres 9.0
BrowserFirefox 17
PHP Version5.3.3
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon testlink.png [^] (279,765 bytes) 2012-11-21 16:08

- Relationships

-  Notes
(0017872)
deallain (reporter)
2012-11-22 10:38

Error message with Firebug :

ReferenceError: FCKeditorAPI is not defined

for (var editorname in FCKeditorAPI.Instances) {

checkmodified.js (ligne 54)
(0017873)
twelve (reporter)
2012-11-22 12:36

This is a known bug of those old FCK editor versions: https://bugzilla.mozilla.org/show_bug.cgi?id=814019 [^]
FCK editor must be updated / patched
(0017875)
paontis (reporter)
2012-11-22 14:25

Foolowing the instructions given in the note 0005359:0017873 , the faster patch to be applied is to modify the file:
      third_party/fckeditor/fckeditor_php5.php
at line 58:

function FCKeditor_IsCompatibleBrowser()
{
    [...]
    else if ( strpos($sAgent, 'Gecko/') !== false )
    {
        $iVersion = (int)substr($sAgent, strpos($sAgent, 'Gecko/') + 6, 8) ;
        //return ($iVersion >= 20030210) ; // modify here
        return true ;
    }
   [...]
}
(0017877)
twelve (reporter)
2012-11-22 16:32

This change would mark every Browser with "Gecko/" in its useragent string as compatible. Not a big problem, but maybe someone will create a better patch, since FCKEditor is used in many projects.
There are also many other places where FCKEditor engages in useragent sniffing.
(0017881)
fman (administrator)
2012-11-22 20:25

My 5 cents
third_party/fckeditor/fckeditor_php5.php
Always inside function FCKeditor_IsCompatibleBrowser()

else if ( strpos($sAgent, 'Gecko/') !== false )
{
    $start = strpos($sAgent, 'Gecko/') + 6;
    $end = strpos($sAgent,' Firefox/');
    $fVersion = -1;
    if($start !== FALSE && $end !== FALSE)
    {
      $fVersion = (float) substr($sAgent,$start,$end-$start);
    }
    $iVersion = (int)substr($sAgent, strpos($sAgent, 'Gecko/') + 6, 8) ;
    return ($iVersion >= 20030210 || $fVersion >= 17.0) ;
}

- Issue History
Date Modified Username Field Change
2012-11-21 16:08 mcosorio New Issue
2012-11-21 16:08 mcosorio File Added: testlink.png
2012-11-22 10:38 deallain Note Added: 0017872
2012-11-22 12:36 twelve Note Added: 0017873
2012-11-22 14:25 paontis Note Added: 0017875
2012-11-22 16:32 twelve Note Added: 0017877
2012-11-22 20:25 fman Note Added: 0017881
2012-11-24 07:29 fman Task Workflow Status TBD => READY FOR TESTING
2012-11-24 07:29 fman Status new => resolved
2012-11-24 07:29 fman Fixed in Version => 1.9.5 (2012 Q4 - bug fixing)
2012-11-24 07:29 fman Resolution open => fixed
2012-11-24 07:29 fman Assigned To => fman
2013-05-30 19:42 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker