Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005344TestLinkAssign Test Case Executionpublic2012-11-14 05:012013-05-26 20:06
Reporterplongthanh 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version1.9.5 (2012 Q4 - bug fixing) 
Summary0005344: BULK EXECUTION - Tester A can execute test case that assigned to Tester B
DescriptionI config as following:

$tlCfg->exec_cfg->show_testsuite_contents = ENABLED;
$tlCfg->exec_cfg->view_mode->tester='all';

I login with tester account -> then I go to "Test Execution" page -> select a test suite that assigned to other tester (not me). On the UI, I can log test result for all test case.

I think it is not good if I can execute test case of other tester.
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox, Google Chrome
PHP Version5.3.10
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon [Issue-5344]_Result_after_modify_code.PNG [^] (81,789 bytes) 2012-11-19 08:14

- Relationships
child of 0005193closedfman Availables hot-fixes for 1.9.4 & How To get full fixed package from gitorious 

-  Notes
(0017815)
fman (administrator)
2012-11-14 06:23

1. what happens if you point to specific test case ?

// Filter Test cases a user with tester role can VIEW depending on
// test execution assignment.

// all: all test cases.
// assigned_to_me: test cases assigned to logged user.
// assigned_to_me_or_free: test cases assigned to logged user or not assigned
$tlCfg->exec_cfg->view_mode->tester='assigned_to_me';

// Filter Test cases a user with tester role can EXECUTE depending on
// test execution assignment.

// all: all test cases.
// assigned_to_me: test cases assigned to logged user.
// assigned_to_me_or_free: test cases assigned to logged user or not assigned
$tlCfg->exec_cfg->exec_mode->tester='assigned_to_me';

what are the config of these options for you ?
(0017817)
plongthanh (reporter)
2012-11-14 06:32

>1. what happens if you point to specific test case ?
If I point to specific test case, I can not execute. It is good.

>$tlCfg->exec_cfg->view_mode->tester='all';
I set to "all" because I want all tester can see test result of other tester

>$tlCfg->exec_cfg->exec_mode->tester='assigned_to_me';
By default, I use this config.

I think problem come from following setting: $tlCfg->exec_cfg->show_testsuite_contents = ENABLED;
(0017820)
fman (administrator)
2012-11-14 22:21

Please try with
http://gitorious.org/testlink-ga/testlink-code/commit/3852512a011bc1e841c0d221855d58f3123c303a [^]

and provide feedback
(0017839)
plongthanh (reporter)
2012-11-19 08:17

>Please try with
>http://gitorious.org/testlink-ga/testlink-code/commit/3852512a011bc1e841c0d221855d58f3123c303a [^] [^]
>and provide feedback

Sorry for my late reply.
Today, I modified "execSetResults.tpl" as your guideline.
The result seem very good.
Please see attached file: "[Issue-5344]_Result_after_modify_code.PNG"

- Issue History
Date Modified Username Field Change
2012-11-14 05:01 plongthanh New Issue
2012-11-14 06:23 fman Note Added: 0017815
2012-11-14 06:32 plongthanh Note Added: 0017817
2012-11-14 21:27 fman Summary Tester A can execute test case that assigned to Tester B by log test result on parent test suite => BULK EXECUTION - Tester A can execute test case that assigned to Tester B
2012-11-14 21:27 fman Assigned To => fman
2012-11-14 21:27 fman Status new => assigned
2012-11-14 22:19 fman Tag Attached: TO BE FIXED on 2.0
2012-11-14 22:21 fman Note Added: 0017820
2012-11-14 22:21 fman Relationship added child of 0005193
2012-11-15 10:05 fman Status assigned => feedback
2012-11-19 08:14 plongthanh File Added: [Issue-5344]_Result_after_modify_code.PNG
2012-11-19 08:17 plongthanh Note Added: 0017839
2012-11-19 08:17 plongthanh Status feedback => assigned
2012-11-19 15:23 fman Task Workflow Status TBD => READY FOR TESTING
2012-11-19 15:23 fman Status assigned => resolved
2012-11-19 15:23 fman Fixed in Version => 1.9.5 (2012 Q4 - bug fixing)
2012-11-19 15:23 fman Resolution open => fixed
2013-05-26 20:06 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker