Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005322TestLinkTest Specificationpublic2012-11-05 10:542013-05-22 20:56
Reporterlbprakbits 
Assigned Tofman 
PrioritylowSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version1.9.7 (2013 Q2 - bug fixing) 
Summary0005322: Link to another test case via ID within TestLink (test case reuse)
DescriptionA simple way to create a link to another test case in the test case summary would improve usability. (Unless there already is a way to do this, then I just could not find it)
At the moment, you could insert the complete direct link of the other test case, but some syntax like "#<test-case-ID>" would be easier to use.

Also have a look at: http://www.teamst.org/forum/viewtopic.php?f=5&t=768 [^]
TagsTest Case Reuse
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0004796closedfman Test Case reuse - Quick & Dirty Approach 
child of 0005551closedfman Availables hot-fixes for 1.9.6 & How To get full fixed package from gitorious 

-  Notes
(0017769)
fman (administrator)
2012-11-05 11:32

We have provided following solution
http://mantis.testlink.org/view.php?id=4796 [^]

(also described on forum on FAQ section)
(0017770)
lbprakbits (reporter)
2012-11-05 13:29

Ok, thank you.
That does work, but it would be even better if you could provide a shorter syntax for this, like in Mantis, where you only use # instead of the javascript function.
(0018625)
fman (administrator)
2013-04-04 20:19
edited on: 2013-04-04 20:19

New possibility

[ghost]"TestCase":"FULL EXTERNAL TEST CASE ID","Version":"Version number"[/ghost]

Example:


Re: How To - Reuse Test Case

Postby fman ยป Thu Apr 04, 2013 8:16 pm
New!!, Used same pattern already used for Test Case STEP REUSE

following string has to be written on summary or preconditions:

[ghost]"TestCase":"FULL EXTERNAL TEST CASE ID","Version":"Version number"[/ghost]

During rendering content of sumary or preconditions will be replace with href
to javascript function to open in a new window the referenced test case.

Example:
Test project name = 'Test Issue 555'
Test Case Prefix = 'DXI'
You create Test Case 'DXI-1' with 3 steps
Then you Create 'DXI-2' and want to create a reference/link to DXI-1 version 1.

You write on preconditions
[ghost]"TestCase":"DXI-1","Version":1[/ghost]

IMPORTATE NOTICE
Test Case External ID MUST BE enclosed bewteen " (DOUBLE QUOTES)
Version number MUST BE enclosed bewteen " (DOUBLE QUOTES)

(0018899)
chemchoum (reporter)
2013-05-07 14:31

I tested this new feature and so far my teammate are so exited to starting using it. great job guys.

The only thing I can say is that it will be better if we get the linked test case on execution mode (if it's in the same test plan) when we use the link on execution.
(0018900)
fman (administrator)
2013-05-07 14:39

>> I tested this new feature and so far my teammate are so exited to starting
>> using it. great job guys.
great, may be is time to think about a donation ? ;)

>> The only thing I can say is that it will be better if we get the linked test
>> case on execution mode (if it's in the same test plan) when we use the link on >> execution.
wolud you mind to refine your explanation in a '.. for dummies way?'
(0018901)
chemchoum (reporter)
2013-05-07 17:07

Let say test Cases 'DXI-1' and 'DXI-2' are both selected in the same test plan.
when executing the test case 'DXI-2' we have as precondition to execute the test case 'DXI-1' first since this last is linked to the first. So when we click on the link we need to get the execution page of 'DXI-1'.
it doesn't matter if 'DXI-1' has been already tested since we my need to re-execute it again or at least we can see the "Execution history" section from its execution page
(0018902)
fman (administrator)
2013-05-07 17:33

You need to open a different issue, because this is different to test case reuse.
What do you want is to be redirected to execution of DXI-1.
This means we need to know the context (design / execution) where we are doing rendering and do render in a different way.
May be it's no so complicated but need to be analized.
(0018922)
chemchoum (reporter)
2013-05-09 15:04

>> You need to open a different issue, because this is different to test case reuse.
done see 0005700 issue

- Issue History
Date Modified Username Field Change
2012-11-05 10:54 lbprakbits New Issue
2012-11-05 11:32 fman Note Added: 0017769
2012-11-05 11:32 fman Relationship added related to 0004796
2012-11-05 11:33 fman Product Version => 1.9.4 (2012 Q3 - bug fixing)
2012-11-05 13:29 lbprakbits Note Added: 0017770
2012-11-05 13:57 fman Priority normal => low
2013-04-04 20:19 fman Note Added: 0018625
2013-04-04 20:19 fman Note Edited: 0018625 View Revisions
2013-04-04 20:23 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2013-04-04 20:23 fman Fixed in Version => 1.9.7 (2013 Q2 - bug fixing)
2013-04-04 20:24 fman Status new => resolved
2013-04-04 20:24 fman Resolution open => fixed
2013-04-04 20:24 fman Assigned To => fman
2013-04-04 20:24 fman Relationship added child of 0005551
2013-05-07 14:31 chemchoum Note Added: 0018899
2013-05-07 14:39 fman Note Added: 0018900
2013-05-07 17:07 chemchoum Note Added: 0018901
2013-05-07 17:33 fman Note Added: 0018902
2013-05-09 15:04 chemchoum Note Added: 0018922
2013-05-15 18:15 fman Summary Link to another test case via ID within TestLink => Link to another test case via ID within TestLink (test case reuse)
2013-05-15 18:15 fman Tag Attached: Test Case Reuse
2013-05-22 20:56 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker