Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005309TestLinkExport/Importpublic2012-10-26 04:452013-05-26 18:52
Reportersujataverma3 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWin XPOS Version
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version1.9.6 (2013 Q1 - bug fixing) 
Summary0005309: Test case summary and Test case ID getting duplicated->import the Test specification XML file inside subtree
DescriptionAll test summaries and test case IDs has to be unique but if we import the same xml inside the Test specification branch ( inside Test suites) , the ID and title duplication check is not present and it is accepting the duplicate values.

Steps To Reproduce1) Create Test project-> Test Plan

2) Go to test specification , import given xml file ( Test suit A and test suit B gets created with TC id 1, 2, 3,4)

3) Now go to Test Suit A -> again import the same xml file ( again Test suit A and B gets created with same test cases ids) -> issue

4) Expected behavior-> The title and test case id should be unique even if we are importing the same file inside the branch.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL 5.1.30
BrowserFirefox 14
PHP Version5.2.8
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon TCID duplication.jpg [^] (38,932 bytes) 2012-10-26 04:45


xml file icon testproject-deep.xml [^] (3,073 bytes) 2012-10-26 04:46
jpg file icon Test_specification_page.jpg [^] (138,147 bytes) 2012-10-26 06:35


jpg file icon Duplicate.jpg [^] (101,461 bytes) 2012-10-26 10:04

- Relationships
has duplicate 0005468closedfman TC with same ID after import within one project 
related to 0005404closedfman Test Specification Test case Filters does not show all slected test id 
child of 0005406closedfman Availables hot-fixes for 1.9.5 & How To get full fixed package from gitorious 

-  Notes
(0017741)
fman (administrator)
2012-10-26 05:34

Thanks, will give a look.
What is missing is the setup you have provided on LAUNCH SCREEN, because some setting can affect this.
Would you mind adding also this info ?.

What is WRONG IS THAT EXTERNAL-ID generated by TL is the same, but SAME TITLE UNDER DIFFERENT branch is OK, because name IS ONLY CHANGED IF A SIBLING WITH SAME NAME is FOUND, otherwise name is not changed.
(0017743)
sujataverma3 (reporter)
2012-10-26 06:14

Not sure which "Launch Screen" you are referring to ? Is it the main page ?

I think Same TITLE under different branch-> OK

External ID should be changed.
(0017744)
fman (administrator)
2012-10-26 07:40

I mean the page that is presented when you request import, where you do the file upload
(0017745)
sujataverma3 (reporter)
2012-10-26 10:06

Ok, uploaded. thanks.

- Issue History
Date Modified Username Field Change
2012-10-26 04:45 sujataverma3 New Issue
2012-10-26 04:45 sujataverma3 File Added: TCID duplication.jpg
2012-10-26 04:46 sujataverma3 File Added: testproject-deep.xml
2012-10-26 05:34 fman Note Added: 0017741
2012-10-26 06:14 sujataverma3 Note Added: 0017743
2012-10-26 06:35 sujataverma3 File Added: Test_specification_page.jpg
2012-10-26 07:40 fman Note Added: 0017744
2012-10-26 10:04 sujataverma3 File Added: Duplicate.jpg
2012-10-26 10:06 sujataverma3 Note Added: 0017745
2012-12-09 18:00 fman Relationship added related to 0005404
2012-12-31 14:00 fman Task Workflow Status TBD => READY FOR TESTING
2012-12-31 14:00 fman Status new => resolved
2012-12-31 14:00 fman Fixed in Version => 1.9.6 (2013 Q1 - bug fixing)
2012-12-31 14:00 fman Resolution open => fixed
2012-12-31 14:00 fman Assigned To => fman
2012-12-31 14:01 fman Relationship added child of 0005406
2013-01-14 10:51 fman Relationship added has duplicate 0005468
2013-05-26 18:52 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker