Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005304TestLinkExport/Importpublic2012-10-23 15:292013-05-26 20:06
Reporterguest 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version1.9.5 (2012 Q4 - bug fixing) 
Summary0005304: import of simple XML results file fails : external_id is not recognized
DescriptionUsing a simple xml result file with following content :

<?xml version="1.0" encoding="UTF-8"?>
<results>
<testcase external_id="TAU-1" >
<tester>admin</tester>
<timestamp>2012-02-20 14:00:00</timestamp>
<result>p</result>
<notes></notes>
</testcase>
</results>

import of the TC worked fine with Testlink 1.9.3
BUT now fails with Testlink 1.9.4

Error message is :
Import TestCase data : Test Case TAU-1 not found in test plan- results are not imported!

BUT the Test Case TAU-1 exist in the test plan, I can see it
Steps To ReproduceCreate a Project

Import the Test Case in 1.9.4 with following TC XML file :
<?xml version="1.0" encoding="UTF-8"?>
<testsuite name="RT 1.1">
        <details><![CDATA[Release Testing v1,1]]></details>
            <testcase name="click on the icon">
            <node_order><![CDATA[1]]></node_order>
            <summary><![CDATA[click on the icon]]></summary>
            <preconditions><![CDATA[sw installed]]></preconditions>
            <steps><step><step_number><![CDATA[1]]></step_number><actions><![CDATA[click on the icon]]></actions>
            <expectedresults><![CDATA[appli launched]]></expectedresults></step></steps>
        </testcase>
</testsuite>

Create a Test Plan, then a build

Import the XML result file

you will see error message with testlink 1.9.4,
import will be successfull with 1.9.3
TagsNo tags attached.
Database (MySQL,Postgres,etc)mySQL 10
BrowserFirefox 16.0.1
PHP VersionPHP 5.3.3
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filesjpg file icon ScreenShot119.jpg [^] (16,552 bytes) 2012-10-23 15:29

- Relationships
duplicate of 0005257closedfman Testcase exported for id/external id not able to import same for result update 
has duplicate 0005525closedfman Test Case Execution Results import doesn't works 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2012-10-23 15:29 guest New Issue
2012-10-23 15:29 guest File Added: ScreenShot119.jpg
2012-10-23 15:56 fman Relationship added duplicate of 0005257
2012-10-23 15:56 fman Status new => resolved
2012-10-23 15:56 fman Fixed in Version => 1.9.5 (2012 Q4 - bug fixing)
2012-10-23 15:56 fman Resolution open => duplicate
2012-10-23 15:56 fman Assigned To => fman
2013-02-12 20:25 fman Relationship added has duplicate 0005525
2013-05-26 20:06 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker