Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005278TestLinkIssue Tracker managementpublic2012-10-11 12:352013-05-26 20:06
Reporterdrblast 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
Platformi386OSWindowsOS Version7
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version 
Summary0005278: PHP.INI ISSUE - Error occures when open a Test for execution (BTS Jira v5.0.6)
DescriptionConfigured Jira.
Tried to open a test for execution and exception was shown:
 Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'SoapClient.class.php' (include_path='.;C:\php\pear;.;C:\wamp\www\testlink-ga-testlink-code\lib\functions\;C:\wamp\www\testlink-ga-testlink-code\lib\issuetrackerintegration\;C:\wamp\www\testlink-ga-testlink-code\third_party\') in C:\wamp\www\testlink-ga-testlink-code\lib\functions\common.php on line 99
Call Stack
# Time Memory Function Location
1 0.0129 817912 {main}( ) ..\execSetResults.php:0
2 0.1416 10951048 tlIssueTracker->getInterfaceObject( ) ..\execSetResults.php:50
3 0.1468 11112864 jirasoapInterface->__construct( ) ..\tlIssueTracker.class.php:608
4 0.1469 11113168 jirasoapInterface->connect( ) ..\jirasoapInterface.class.php:40
5 0.1469 11113368 jirasoapInterface->getClient( ) ..\jirasoapInterface.class.php:184
6 0.1469 11114312 tlAutoload( ) ..\jirasoapInterface.class.php:0
Steps To ReproduceConfigure Jira integration as it shown in the example.
Assign BTS to Test Plan
Open Test Execution
Click Test Case
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version5.3.13
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
related to 0005281closedfman On list view add check to environment (example SOAP ext is enabled?) and display status 

-  Notes
(0017654)
fman (administrator)
2012-10-11 18:43

tested with LAMPP on linux => unable to reproduce
(0017657)
drblast (reporter)
2012-10-12 06:33

May be the reason is WampServer Version 2.2? I've used it to intall Apache Web server 2.22 and php 5.3.13.
Also in logs you can see (include_path='.;C:\php\pear; ... but I haven't such folder on my computer. All php files are situated in the wamp folder.
The same description was on testlink forum http://www.teamst.org/forum/viewtopic.php?f=11&t=7023&sid=f25f44abbe8cd95e6856e29b96869c41 [^] (this is not my post)
(0017660)
fman (administrator)
2012-10-12 07:55

can not said, I've never used WAMPP
when you get this kind of error:
common.php on line 99

normally there is some issue with php autoload feature.
Unfortunatelly have no idea how to help you
(0017661)
drblast (reporter)
2012-10-12 12:27

I've resolved the problem!
In php.ini extention php_soap.dll should be enabled.
So php_soap.dll must be in php ext directory.
Keywords were 'SoapClient.class.php' not found, not common.php line 99 :-)
(0017662)
fman (administrator)
2012-10-12 14:05

Great you solved it!
I will try to post on forum
(0017663)
fman (administrator)
2012-10-12 14:05

not a TL issue
(0017665)
fman (administrator)
2012-10-12 18:36

@drblast
Would you mind trying fix provided in related issue and provide feedback ?

- Issue History
Date Modified Username Field Change
2012-10-11 12:35 drblast New Issue
2012-10-11 18:43 fman Note Added: 0017654
2012-10-11 18:55 fman Assigned To => fman
2012-10-11 18:55 fman Status new => feedback
2012-10-12 06:33 drblast Note Added: 0017657
2012-10-12 06:33 drblast Status feedback => assigned
2012-10-12 07:55 fman Note Added: 0017660
2012-10-12 12:27 drblast Note Added: 0017661
2012-10-12 14:05 fman Note Added: 0017662
2012-10-12 14:05 fman Note Added: 0017663
2012-10-12 14:05 fman Status assigned => resolved
2012-10-12 14:05 fman Resolution open => no change required
2012-10-12 14:06 fman Summary Error occures when open a Test for execution (BTS Jira v5.0.6) => PHP.INI ISSUE - Error occures when open a Test for execution (BTS Jira v5.0.6)
2012-10-12 18:08 fman Relationship added related to 0005281
2012-10-12 18:36 fman Note Added: 0017665
2013-05-26 20:06 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker