Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005229TestLinkFilterspublic2012-09-13 11:542013-05-26 18:53
Reporterasimon 
Assigned Toasimon 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindows 7OS VersionWindows 7 (x64)
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version 
Summary0005229: Filtering by the value of custom fields is not working on test execution
DescriptionFiltering by the value of custom fields is not working on test execution. It always shows all assigned test cases, regardless of which value has been chosen in the filter panel for any custom field.
Steps To Reproduce1. Create a new test project "filter test". In that test project, create a testsuite "suite 1" and two test cases "test case 1" and "test case 2".
2. Create new custom field, e.g. with the following preferences:
   - Name "CF_TC_STATUS"
   - Label "Status"
   - Available for "Test Case"
   - Type "list"
   - possible values: "draft|needs review|needs rework|ready|"
   - enable on "Test Spec Design"
   - Display on test execution "Yes"
Assign this custom field to test project "filter test".
3. Edit test case 1, set "Status" to "needs rework".
4. Create a test plan and a build. Add both test cases to this test plan and assign execution to yourself.
5. Now try to filter by value "needs rework" of this custom field on test execution.
=> It will always display both test cases, regardless of which value of the custom field has been chosen in the filter panel.
Additional InformationThis functionality was working in version 1.9.3.
Filtering has been refactored for version 1.9.4 and this specific filter has not been implemented yet.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
child of 0005193closedfman Availables hot-fixes for 1.9.4 & How To get full fixed package from gitorious 

-  Notes
(0017469)
fman (administrator)
2012-09-13 15:24
edited on: 2012-09-13 15:26

IS MANDATORY that this will be fixed ALSO on 2.0 before doing any other work on 1.9.4.

AND IS ABSOLUTELY critic that performance be evaluated AND DOCUMENTED with this filter and without filter, because we can not allow performance degradation

(0017546)
asimon (developer)
2012-09-24 08:05

http://gitorious.org/testlink-ga/testlink-code/commit/8cea205c252d0a2ab9b2c887537462f61c5eca14 [^]

Filtering by custom field values on test execution is now working again.

It was implemented using a call to the same function that is used for filtering on test specification tree => code reuse.

- Issue History
Date Modified Username Field Change
2012-09-13 11:54 asimon New Issue
2012-09-13 11:54 asimon Status new => assigned
2012-09-13 11:54 asimon Assigned To => asimon
2012-09-13 15:24 fman Note Added: 0017469
2012-09-13 15:26 fman Note Edited: 0017469 View Revisions
2012-09-24 08:05 asimon Note Added: 0017546
2012-09-24 08:05 asimon Task Workflow Status TBD => READY FOR TESTING
2012-09-24 08:05 asimon Status assigned => resolved
2012-09-24 08:05 asimon Resolution open => fixed
2012-09-24 08:05 asimon Relationship added child of 0005193
2013-05-26 18:53 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker