Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005228TestLinkFilterspublic2012-09-13 09:342013-05-26 18:53
Reporterasimon 
Assigned Toasimon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindows 7OS VersionWindows 7 (x64)
Product Version1.9.4 (2012 Q3 - bug fixing) 
Fixed in Version 
Summary0005228: Filter use on test spec causes "undefined index" warning in event log for every test case with no active version
DescriptionWhen using filters on test specification, every test case that does not have at least one active version causes an "undefined index" warning written to the event log.
Steps To ReproduceCreate at least one test case with multiple versions.
Deactivate *all* versions of that test case.
Use any filter available on test specification.
See event log.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
child of 0005193closedfman Availables hot-fixes for 1.9.4 & How To get full fixed package from gitorious 

-  Notes
(0017467)
asimon (developer)
2012-09-13 12:00

Fixed for branch testlink_1_9: https://gitorious.org/testlink-ga/testlink-code/commit/538420f56ec4caf315ba31ce8f547a1801cd991a [^]

No change on branch master needed. The warning was caused by code that was only introduced in branch 1.9.
(0017468)
fman (administrator)
2012-09-13 15:22

>> No change on branch master needed.
>> The warning was caused by code that was only introduced in branch 1.9.
this is not true, we need in this situation start doing refactoring of 2.0
if we do not proceed this way I will find all this work to do for 2.0 release.

- Issue History
Date Modified Username Field Change
2012-09-13 09:34 asimon New Issue
2012-09-13 09:34 asimon Status new => assigned
2012-09-13 09:34 asimon Assigned To => asimon
2012-09-13 12:00 asimon Note Added: 0017467
2012-09-13 12:00 asimon Status assigned => resolved
2012-09-13 12:00 asimon Resolution open => fixed
2012-09-13 12:00 asimon Relationship added child of 0005193
2012-09-13 15:22 fman Note Added: 0017468
2013-05-26 18:53 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker