Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005226TestLinkFilterspublic2012-09-12 16:342013-05-26 18:53
Reporteransar 
Assigned Toasimon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version 
Summary0005226: 1.9.4 - Execute Tests - Filter by "Not Run" and "All Builds" returning empty
DescriptionWe just upgraded from TestLink 1.9.3 to TestLink 1.9.4.

When Executing test cases and filtering by "Not Run" and "All Builds", the results are returning nothing. In 1.9.3, this same filter worked fine and would return the expected results.
Steps To Reproduce1. Select "Execute Tests".
2. Filter by: Result: "Not Run"
3. Filter by: on: "All Builds"
4. Notice no results are returned.
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox, IE9
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon NoResults.png [^] (37,779 bytes) 2012-09-12 20:49


xml file icon linkedItems_1.9.4.xml [^] (1,256 bytes) 2012-09-12 21:05
xml file icon TestLink Filtering.testsuite-deep.xml [^] (1,270 bytes) 2012-09-12 21:05

- Relationships
related to 0005240new Query: Regarding issue 5226 resolution 
child of 0005193closedfman Availables hot-fixes for 1.9.4 & How To get full fixed package from gitorious 

-  Notes
(0017459)
fman (administrator)
2012-09-12 17:41

unfortunatelly details are not enough, we needed:

1. xml file with test specification
2. xml file with test plan
3. really detailed steps to reproduce i.e. a real test case

without requested info we will be forced to close
(0017463)
ansar (reporter)
2012-09-12 21:26

Ok, lets see if this helps. I uploaded a testplan and a testsuite with 3 test cases.

To Reproduce this, here is what I did:

1. Create new Project.
2. Create new Test Plan.
3. Create new build.
4. Create new test suite.
5. Create 3 test cases in the above test suite.
6. Add these 3 test cases to the Test Plan and assign to myself.
7. Click on "Execute Tests".
8. Verify that the correct Test Plan and Build are selected.
9. You should now have 3 test cases.
10. Select the first test case and mark it as passed.
11. Create another build and be sure and copy tester assignments.
12. Click on "Execute Tests".
13. Verify that the correct Test Plan and new Build are selected.
14. You should now have 3 test cases.
15. Set Result to Not Run.
16. Set on to ALL Builds.
17. Press the apply button.
18. Note that you won't see any test cases.
(0017464)
sujataverma3 (reporter)
2012-09-13 06:45

I could reproduce the issue, in my setup. Looks like we missed this combination in internal testing. I will update the internal test repository.

As my understanding for above test scenario

The expected result is -> it should show 2 test cases -> as two are not being "Not run" in both the builds.

Also this should be independent of selection of "setting" build i.e. if we select filter as " Not Run", "ALL builds" -> and change "settings" build -> to any of the build -> the expected result -> should be 2

@ansar

Let me know if this is the expected result , you are expecting.
(0017476)
ansar (reporter)
2012-09-13 21:20

That is correct. Well, at least that is what we see in 1.9.3.
(0017495)
fman (administrator)
2012-09-18 20:18
edited on: 2012-09-18 20:24

>> The expected result is -> it should show 2 test cases
Just to be unpolite as usual, next time I do not plan to have to guess what user expects => REPORTER is responsible to provide an absolute complete test case
(that is the work has been completed by sujataverma3)

(0017496)
fman (administrator)
2012-09-18 20:20

@sujataverma3
Great that you will update our spec. Thanks a lot
(0017499)
asimon (developer)
2012-09-19 16:21

I've taken a deeper look into this issue and the current filtering mechanisms. I found even some more scenarios in the result filtering that were not working correctly besides this specific one.

1. When *not using platforms* I could reproduce this exactly as described in comment #17463.

2. When *using platforms* and filtering in advanced filter mode for multiple statuses combined, e.g. "not run or blocked on all builds", the results were also incorrect.

Example:
- filter "not run on all builds" finds two test cases
- filter "failed on all builds" returns no test cases
=> The advanced filter combination "not run/failed on all builds" should return two test cases but did not return anything at all.

Another example:
- filter "passed on all builds" finds two test cases
- filter "failed on all builds" returns no test cases
- filter "blocked on all builds" returns no test cases
=> The advanced filter combination "passed or failed or blocked on all builds" should return two test cases but did not return anything at all.

There were some parts of the code that needed to be fixed but now all these scenarios are working fine now.

https://gitorious.org/testlink-ga/testlink-code/commit/2efd976edb48bae5cf6b570db26e36938d78e85e [^]
(0017500)
fman (administrator)
2012-09-19 16:50

Please create all needed test cases with very good details, on our test repository ASAP.
This will be the only way we will do regression tests.
I would like to have all these tests in order to do a test run.

- Issue History
Date Modified Username Field Change
2012-09-12 16:34 ansar New Issue
2012-09-12 17:41 fman Note Added: 0017459
2012-09-12 20:49 ansar Note Added: 0017462
2012-09-12 20:49 ansar File Added: NoResults.png
2012-09-12 21:05 ansar File Added: linkedItems_1.9.4.xml
2012-09-12 21:05 ansar File Added: TestLink Filtering.testsuite-deep.xml
2012-09-12 21:26 ansar Note Added: 0017463
2012-09-13 06:45 sujataverma3 Note Added: 0017464
2012-09-13 21:20 ansar Note Added: 0017476
2012-09-18 12:00 asimon Assigned To => asimon
2012-09-18 12:00 asimon Status new => assigned
2012-09-18 20:18 fman Note Added: 0017495
2012-09-18 20:19 fman Note Deleted: 0017462
2012-09-18 20:20 fman Note Added: 0017496
2012-09-18 20:24 fman Note Edited: 0017495 View Revisions
2012-09-19 16:21 asimon PHP Version 5.3.2 =>
2012-09-19 16:21 asimon Task Workflow Status TBD => READY FOR TESTING
2012-09-19 16:21 asimon Note Added: 0017499
2012-09-19 16:21 asimon Status assigned => resolved
2012-09-19 16:21 asimon Resolution open => fixed
2012-09-19 16:22 asimon Relationship added child of 0005193
2012-09-19 16:50 fman Note Added: 0017500
2012-09-19 16:50 fman Tag Attached: TO BE FIXED on 2.0
2012-09-20 21:09 fman Relationship added related to 0005240
2013-05-26 18:53 fman Status resolved => closed



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker