Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005184TestLinkReportspublic2012-08-30 05:442012-09-01 19:58
Reporterimraneo 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0005184: Duplicate test cases shown in results by tester
DescriptionMultiple results in Result by tester.
See attached picture: Every 2 lines within a test suite are the same.
This issue reflects the numbers in the "results by tester per build page" too.
Steps To ReproduceRun "Results by Tester per Build".
So read results by Build and by Tester.
Click on one Tester, tcAssignedToUser.php report opens.

As the screenshot attached, the suite "Functions/Real Time Clock (Plug-In)" has it's test cases displayed twice each.
This affects only particular test suites. This symptom occurs regardless of run status, meaning if the testcase passes, there will be 2 pass statuses, and so on.

This also affects the listing of "Results by Tester per Build". Example: If the tester has 100 test cases no run and 200 Passed, the listing here will show 200 not run, 400 passed, basically doubling all numbers. Since it happens on certain test suites only, these total numbers are not accurate, and poses quite a problem as our management looks at it.
Additional InformationThis anomaly is an extension of issue 0004593.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserAny
PHP Version5.3.5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon duplicate_results.jpg [^] (232,332 bytes) 2012-08-30 05:44


jpg file icon duplicate_results2.jpg [^] (79,254 bytes) 2012-08-30 05:44

- Relationships

-  Notes
(0017241)
fman (administrator)
2012-09-01 19:58

1.9.4 released

- Issue History
Date Modified Username Field Change
2012-08-30 05:44 imraneo New Issue
2012-08-30 05:44 imraneo File Added: duplicate_results.jpg
2012-08-30 05:44 imraneo File Added: duplicate_results2.jpg
2012-08-30 07:54 fman Task Workflow Status TBD => READY FOR TESTING
2012-08-30 07:54 fman Status new => resolved
2012-08-30 07:54 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-08-30 07:54 fman Resolution open => fixed
2012-08-30 07:54 fman Assigned To => fman
2012-09-01 19:58 fman Note Added: 0017241
2012-09-01 19:58 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker