Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005182TestLinkTest Plan - Add/Remove Test Casespublic2012-08-29 11:442012-09-01 19:56
Reportersujataverma3 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWin XPOS Version
Product Version1.9.4 Preview 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0005182: Add/Remove Test Cases -> Trying to assign new platform to executed test cases-> DB Error
DescriptionIf we try to assign new Platform to already executed test cases on another platform, the following DB error is displayed.

 DB Access Error - debug_print_backtrace() OUTPUT START

 ==============================================================================

#0 database->exec_query() called at [/home/testlink/demo.testlink.org/tlqarepo/lib/functions/testplan.class.php:516]
#1 testplan->link_tcversions() called at [/home/testlink/demo.testlink.org/tlqarepo/lib/plan/planAddTC.php:89]

 ==============================================================================
Steps To Reproduce
1) Go to demo site http://demo.testlink.org/tlqarepo/index.php [^]

2) Go to "Add/Remove Test Cases"

3) Click on Requirement Feature-> Requirement Filters

4) give below parameters

Assign to user on ADD -> sv3 , on build-> TL194_QA_20120827

Check / uncheck all test cases-> Dummy Platform-Bug Verification-> Click on for

"adding"

5) Now click on "Add/Remove Selected"

6) DB error is displayed
Tags1.9.4 PREVIEW
Database (MySQL,Postgres,etc)MySQL 5.1.30
BrowserFirefox 14
PHP Version5.2.8
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon Database_error_Add_platforms_demo_site.jpg [^] (216,396 bytes) 2012-08-29 11:44


jpg file icon Database_error_Add_platforms.jpg [^] (169,516 bytes) 2012-08-29 11:45

- Relationships

-  Notes
(0017175)
fman (administrator)
2012-08-29 17:21

On event viewer:
ERROR ON exec_query() - database.class.php
1062 - Duplicate entry '234-640-22' for key 'tlqa_testplan_tcversions_tplan_tcversion' -

/*Class:testplan - Method: link_tcversions */ INSERT INTO tlqa_testplan_tcversions (testplan_id,author_id,creation_ts,tcversion_id,platform_id) VALUES (234,1,'2012-08-29 10:19:38',640, 22)
THE MESSAGE : /* Class:testplan - Method: link_tcversions */ INSERT INTO tlqa_testplan_tcversions (testplan_id,author_id,creation_ts,tcversion_id,platform_id) VALUES (234,1,'2012-08-29 10:19:38',640, 22) Query failed: errorcode[1062] errormsg:Duplicate entry '234-640-22' for key 'tlqa_testplan_tcversions_tplan_tcversion'


Seems to be an issue at DB level, because in addition on other test suites can not be reproduced => will close
(0017177)
sujataverma3 (reporter)
2012-08-30 04:21

1) The issue is reproducible 100 % on any test suites.

2) Following condition has to be there , the test case should be executed on one platform. Please follow below steps to reproduce the issue.

3) As you mentioned , it is indeed adding two times , then only the DB error is displayed. But we need to click two times as the color is not changing to yellow for first time addition. I will state the exact steps to reproduce the issue. Even if you feel this is not an issue, please close it again.


a) Create Test Project, Test Plan, Test Cases ( TC1-TC5) , 1 build, 1 platform

b) Go to add remove test cases , add it and assign to admin to platform A and build A

c) Execute the tests, once the test cases are executed , create one more Platform B

d) Add the Platform B

e) Now try to assign only this platform to user admin, on same test cases which were executed above, by following steps as mentioned in bug.

f) Once you click on "Add/Remove selected" , nothing happens, the platform B Color is not changed to "Yellow", but when I verified in Test Execution, actually the platform got assigned.

g) If we try to add again the Platform the DB error is displayed.


The issue i feel is :

1) Once we click on ADD/Remove , the color has not changed to Yellow -> it should change to yellow -> issue

2) As color is not changed to yellow-> if the user again tries to add the platform the DB error is coming.

If we fix first issue, automatically second gets fixed.

It is easily reproducible.
(0017178)
fman (administrator)
2012-08-30 07:52

OK, will recheck, Thanks for your work
(0017213)
fman (administrator)
2012-08-31 18:28

Issue is created by getLinkedTCVersionsSQL(), where platforms where not considered to get Latest Execution.
(0017214)
fman (administrator)
2012-08-31 18:30

https://gitorious.org/testlink-ga/testlink-code/commit/ab13220b444497e2694a272a671fb821ccd10900 [^]
(0017216)
fman (administrator)
2012-09-01 19:56

1.9.4 released

- Issue History
Date Modified Username Field Change
2012-08-29 11:44 sujataverma3 New Issue
2012-08-29 11:44 sujataverma3 File Added: Database_error_Add_platforms_demo_site.jpg
2012-08-29 11:45 sujataverma3 File Added: Database_error_Add_platforms.jpg
2012-08-29 12:20 sujataverma3 Tag Attached: 1.9.4 PREVIEW
2012-08-29 15:59 fman Assigned To => fman
2012-08-29 15:59 fman Status new => assigned
2012-08-29 17:21 fman Note Added: 0017175
2012-08-29 17:21 fman Status assigned => closed
2012-08-29 17:21 fman Resolution open => no change required
2012-08-30 04:21 sujataverma3 Note Added: 0017177
2012-08-30 04:21 sujataverma3 Status closed => assigned
2012-08-30 04:21 sujataverma3 Resolution no change required => reopened
2012-08-30 07:52 fman Note Added: 0017178
2012-08-31 18:28 fman Note Added: 0017213
2012-08-31 18:30 fman Task Workflow Status TBD => READY FOR TESTING
2012-08-31 18:30 fman Note Added: 0017214
2012-08-31 18:30 fman Status assigned => resolved
2012-08-31 18:30 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-08-31 18:30 fman Resolution reopened => fixed
2012-09-01 19:56 fman Note Added: 0017216
2012-09-01 19:56 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker