Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005165TestLinkDatabase MS-SQLpublic2012-08-23 14:262012-09-01 19:56
Reporterfman 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.4 Preview 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0005165: Issues with DISTINCT CLAUSE on TEXT field
DescriptionGot this when trying to add test cases to test plan

ERROR ON exec_query() - database.class.php
421 - SQLState: 42000 Error Code: 421 Message: [Microsoft][SQL Server Native Client 11.0][SQL Server]The text data type cannot be selected as DISTINCT because it is not comparable. SQLState: 42000 Error Code: 421 Message: [Microsoft][SQL Server Native Client 11.0][SQL Server]The text data type cannot be selected as DISTINCT because it is not comparable.
- /* Class:testplan - Method: getLinkedTCVersionsSQL sqlUnion - executions */ SELECT NH_TCASE.id AS tcase_id,NH_TCASE.id AS tc_id,TPTCV.tcversion_id,TCV.version, TCV.tc_external_id AS external_id, TCV.execution_type, TCV.summary, TCV.preconditions,TPTCV.id AS feature_id, TPTCV.platform_id,PLAT.name AS


Seems issue appears because we use generated SQL on UNION, and UNION can apply DISTINCT automatically.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
related to 0005167closedfman replace TEXT with NVARCHAR(MAX) => we will support only SQL SERVER 2005 and UP 

-  Notes
(0017159)
fman (administrator)
2012-08-23 14:48

http://gitorious.org/testlink-ga/testlink-code/commit/5c6c8575767f8e75aec746c33fbe6dd92735546e [^]
(0017227)
fman (administrator)
2012-09-01 19:56

1.9.4 released

- Issue History
Date Modified Username Field Change
2012-08-23 14:26 fman New Issue
2012-08-23 14:26 fman Status new => assigned
2012-08-23 14:26 fman Assigned To => fman
2012-08-23 14:32 fman Description Updated View Revisions
2012-08-23 14:48 fman Task Workflow Status TBD => READY FOR TESTING
2012-08-23 14:48 fman Note Added: 0017159
2012-08-23 14:48 fman Status assigned => resolved
2012-08-23 14:48 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-08-23 14:48 fman Resolution open => fixed
2012-08-23 16:04 fman Relationship added related to 0005167
2012-09-01 19:56 fman Note Added: 0017227
2012-09-01 19:56 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker