Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005159TestLinkExport/Importpublic2012-08-22 09:002012-10-25 13:39
Reportersujataverma3 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWinXPOS Version
Product Version1.9.4 Preview 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0005159: importing duplicate test suites (with option 'Create a new test case with different title') =>test case id is getting duplicated
DescriptionWhile uploading the testsuite two times with selection for duplicates as "Create a new test case with different title" , the test cases are being generated properly with different title but the "Test Case ID" is getting duplicated.

If we select the Test case Id filter , it displays only the first test case added.
Steps To Reproduce1) Create Test Project -> Project A
2) Go to Test specification
3) Import attached test suite xml file twice with selection

Action for duplicates : "Create a new test case with different title"

4) The test cases are getting imported with some debug prints on top.

5) Duplicate test ID can be seen in Test specification tree.
Additional InformationTested on latest tarball (22/8/2012)


http://gitorious.org/testlink-ga/testlink-code/archive-tarball/testlink_1_9 [^]
Tags1.9.4 PREVIEW
Database (MySQL,Postgres,etc)MySQL 5.1.30
BrowserFirefox 14
PHP Version5.2.8
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon TestCase_ID.jpg [^] (158,149 bytes) 2012-08-22 09:00


jpg file icon Duplicate_TestCase.jpg [^] (94,405 bytes) 2012-08-22 09:01


xml file icon testproject-deep.xml [^] (3,073 bytes) 2012-08-22 09:01
jpg file icon TCID duplication.jpg [^] (38,932 bytes) 2012-10-25 11:51

- Relationships

-  Notes
(0017141)
fman (administrator)
2012-08-22 10:12
edited on: 2012-08-22 10:15

>> 4) The test cases are getting imported with some debug prints on top.
this is ERROR not debug, each time you see D ACCESS ERROR is an error

I will try to provide a fix tomorrow

(0017143)
fman (administrator)
2012-08-22 12:47

http://gitorious.org/testlink-ga/testlink-code/commit/01573cb840c5bbc2d7c24af0a41d53b525bb89ea [^]
(0017232)
fman (administrator)
2012-09-01 19:56

1.9.4 released
(0017731)
sujataverma3 (reporter)
2012-10-25 11:51

The issue is solved if the import is done at same level. If the import is done at second/third level the issue still exists. Even the title is getting duplicated.

As the issue is only partially fixed for one case, reopening the bug.

Tested on latest code base 25 oct.
(0017732)
sujataverma3 (reporter)
2012-10-25 11:52

Please see screenshot to understand the issue.
(0017733)
fman (administrator)
2012-10-25 13:38

1. issue as reported was fixed => can not be reopened
2. open a new ond with detailed steps to reproduce and right version

- Issue History
Date Modified Username Field Change
2012-08-22 09:00 sujataverma3 New Issue
2012-08-22 09:00 sujataverma3 File Added: TestCase_ID.jpg
2012-08-22 09:01 sujataverma3 File Added: Duplicate_TestCase.jpg
2012-08-22 09:01 sujataverma3 File Added: testproject-deep.xml
2012-08-22 09:02 sujataverma3 Tag Attached: 1.9.4 PREVIEW
2012-08-22 09:12 fman Assigned To => fman
2012-08-22 09:12 fman Status new => assigned
2012-08-22 10:08 fman Summary Test Specification: For importing duplicate test suites , the test case id is getting duplicated => importing duplicate test suites (with option 'Create a new test case with different title') =>test case id is getting duplicated
2012-08-22 10:12 fman Note Added: 0017141
2012-08-22 10:12 fman Note Edited: 0017141 View Revisions
2012-08-22 10:15 fman Note Edited: 0017141 View Revisions
2012-08-22 12:47 fman Note Added: 0017143
2012-08-22 12:47 fman Task Workflow Status TBD => READY FOR TESTING
2012-08-22 12:47 fman Status assigned => resolved
2012-08-22 12:47 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-08-22 12:47 fman Resolution open => fixed
2012-09-01 19:56 fman Note Added: 0017232
2012-09-01 19:56 fman Status resolved => closed
2012-10-25 11:51 sujataverma3 Note Added: 0017731
2012-10-25 11:51 sujataverma3 Status closed => assigned
2012-10-25 11:51 sujataverma3 Resolution fixed => reopened
2012-10-25 11:51 sujataverma3 File Added: TCID duplication.jpg
2012-10-25 11:52 sujataverma3 Note Added: 0017732
2012-10-25 13:38 fman Note Added: 0017733
2012-10-25 13:39 fman Status assigned => closed
2012-10-25 13:39 fman Resolution reopened => fixed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker