Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005133TestLinkTest Specificationpublic2012-08-08 15:052012-09-01 19:56
ReporterKuiBie 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0005133: Test cases - possibility to have step expected result reuse, as exists for step action
DescriptionIt is possible to reuse tescase steps with the code: [ghost]"Step":1,"TestCase":"DXI-1","Version":1[/ghost]

But this code only works for the steps, it doesn't work for the expected results connected to those steps.

Please add the functionality to reuse expected results.
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)N/A
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesjpg file icon ER_reuse.jpg [^] (61,978 bytes) 2012-08-08 15:05

- Relationships

-  Notes
(0017068)
fman (administrator)
2012-08-08 19:29

>> But this code only works for the steps,
>> it doesn't work for the expected results connected to those steps.
We have never declared that that expected results reuse, is a supported feature.
(0017076)
KuiBie (reporter)
2012-08-10 09:15

It's true you didn't declare that expected results reuse would also be possible.
However because of the way I use Testlink steps and their expected results are deeply connected.
Being able to reuse a step and then having to copy the expected result would still put me in the unwanted situation of having to maintain multiple identical expected results in stead of a "master" expected result.

Because of this I requested expected results reuse.
I really hope this feature can be added.
(0017198)
KuiBie (reporter)
2012-08-30 20:12

I added a fix for this issue on gitorious, and did a merge request.
https://gitorious.org/testlink-ga/testlink-code/merge_requests/6 [^]
Please let me know if I need to change anything.
Thank you.
(0017202)
fman (administrator)
2012-08-31 07:55

ok, we will see when we be able to add this to stable code.
(0017205)
fman (administrator)
2012-08-31 09:27

Same format:
[ghost]"Step":1,"TestCase":"DXI-1","Version":1[/ghost]

will be used for action or expected_results.

fixed with an slighty different implementation.
(0017206)
fman (administrator)
2012-08-31 09:32

https://gitorious.org/testlink-ga/testlink-code/commit/56f141774719dcea3031b3bbf1e420e590c6cf44 [^]
(0017220)
fman (administrator)
2012-09-01 19:56

1.9.4 released

- Issue History
Date Modified Username Field Change
2012-08-08 15:05 KuiBie New Issue
2012-08-08 15:05 KuiBie File Added: ER_reuse.jpg
2012-08-08 19:29 fman Note Added: 0017068
2012-08-08 19:36 fman Summary [1.9.4 PREVIEW] Test case expected result reuse => Test case expected result reuse
2012-08-08 19:37 fman Summary Test case expected result reuse => Test cases - possibility to have step expected result reuse, as exists for step action
2012-08-10 09:15 KuiBie Note Added: 0017076
2012-08-30 20:12 KuiBie Note Added: 0017198
2012-08-31 07:55 fman Note Added: 0017202
2012-08-31 09:27 fman Note Added: 0017205
2012-08-31 09:27 fman Tag Attached: TO BE FIXED on 2.0
2012-08-31 09:32 fman Note Added: 0017206
2012-08-31 09:32 fman Task Workflow Status TBD => READY FOR TESTING
2012-08-31 09:32 fman Status new => resolved
2012-08-31 09:32 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-08-31 09:32 fman Resolution open => fixed
2012-08-31 09:32 fman Assigned To => fman
2012-09-01 19:56 fman Note Added: 0017220
2012-09-01 19:56 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker