Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005121TestLinkTest Specificationpublic2012-08-02 07:432012-09-01 19:59
Reporterjoanna.fugas 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindows 7OS Version
Product Version1.9.4 Preview 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0005121: [1.9.4 PREVIEW] Link to test case execution edit page is invalid
DescriptionThe new feature for viewing the execution history of a test case has link named "edit execution" which does not work and redirects to the main TestLink page.
Steps To Reproduce1) Create test Project
2) Create a test case -> "Test case 1"
3) Create a test plan -> "Test plan 1"
4) Create a build -> "Build 1"
5) Add "Test case 1" to "Test plan 1" assign to "admin" on build "Build 1"
6) Execute the test, assign any result
7) Go to Test Specification
8) Open "Test case 1" and choose "Execution History"
9) On the new window (see attachment) click the icon with a pencil and a piece of paper (it has a tooltip saying "edit execution")
10) TestLink redirects you to the main page after a while
Additional Informationjavascript: openExecEditWindow(2,8,13,1);
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL 5.5.24
BrowserChrome 20
PHP Version5.3.13
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filespng file icon testlink_edit_execution_page.PNG [^] (56,054 bytes) 2012-08-02 07:43

- Relationships

-  Notes
(0017047)
fman (administrator)
2012-08-02 20:36
edited on: 2012-08-02 20:45

checking TestLink event viewer you will be able to get this message:


User 'admin' has insufficient rights for 'any' action on 'editExecution.php'! Exit forced!


This is what is producing the weird effect, and need to be fixed.
Message is misleading, because issue is generated by:

$tlCfg->exec_cfg->edit_notes = DISABLED;


Thanks for you help

(0017048)
fman (administrator)
2012-08-02 21:04

Testlink 1.9
http://gitorious.org/testlink-ga/testlink-code/commit/a7dd5babdddc6a8027be356320866d491facf816 [^]
(0017305)
fman (administrator)
2012-09-01 19:59

1.9.4 released

- Issue History
Date Modified Username Field Change
2012-08-02 07:43 joanna.fugas New Issue
2012-08-02 07:43 joanna.fugas File Added: testlink_edit_execution_page.PNG
2012-08-02 15:31 fman Assigned To => fman
2012-08-02 15:31 fman Status new => assigned
2012-08-02 20:36 fman Note Added: 0017047
2012-08-02 20:38 fman Product Version 1.9.3 (2011 Q3 - bug fixing) => 1.9.4 Preview
2012-08-02 20:45 fman Note Edited: 0017047 View Revisions
2012-08-02 21:04 fman Note Added: 0017048
2012-08-02 21:04 fman Tag Attached: TO BE FIXED on 2.0
2012-08-02 21:04 fman Task Workflow Status TBD => READY FOR TESTING
2012-08-02 21:04 fman Status assigned => resolved
2012-08-02 21:04 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-08-02 21:04 fman Resolution open => fixed
2012-09-01 19:59 fman Note Added: 0017305
2012-09-01 19:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker