Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005095TestLinkExport/Importpublic2012-07-18 13:262015-09-19 08:49
Reporterthomas.peters.al 
Assigned Tofman 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformApache2OSUbuntuOS Version10.04 LTS
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.14 (2015 Q3) 
Summary0005095: Testcases with the same name after import from xml file
DescriptionAfter the import of an xml file I had 2 testcases with the same name. In XML-file there were 3 testcases with the same name and after import one had the original name and the other 2 became the same name Date+"original name".
Afterwards it is not possible to alter one of the TCs without aktering the name.
Steps To ReproduceImport a xml file into testlink with the same title for 3 testcases. (for example from attached xml-file)
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox 14
PHP VersionPHP 5
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Filesxml file icon TestSuite-TL.xml [^] (3,565 bytes) 2012-07-18 13:26
jpg file icon Dup-TC-Import.jpg [^] (188,053 bytes) 2012-07-19 06:33

- Relationships
child of 0006830closedfman Availables hot-fixes for 1.9.13 & How To get full fixed package from GitHub 

-  Notes
(0016985)
fman (administrator)
2012-07-18 17:52

1. in order to test, we need all options you have used at GUI, please attach an screenshoot

2. please explain what is supposed to be the use case to provide in same test suite 4 test cases with same title
(0016987)
thomas.peters.al (reporter)
2012-07-19 06:33

1. options are xml, the attached xml-file, has same name, create a new TC with different title

2. Well I can only tell you that I had it once in a testsuite with 35 TC's. I manually changed all those TC's by adding a custom field entry. Some days later I recognized that I might have forgotten to update 2 TC's as the custom field was empty for them. So I changed it again and noticed this time that it didn't save because of the same name. I know that I could have recognized this earlier but when changing 35 TC's and you mess already with the 16th you don't have a look at the message cause you know it is ok.
I can not really tell you why there were 3 TC's with the same name as I did not write them but it happened to me.
(0016988)
fman (administrator)
2012-07-19 20:59
edited on: 2012-07-19 21:04

with this additional info, we will try to understand what is happening

Please understand that we can not promise to provide an answer on short time, because we are in the process to finish new release 1.9.4

You receive a mail from mantis if we act on this ticket


one thought:
we need to add a better check, right now I think we are checking is there is a conflict between an existent name and name we got form XML, but we have forgot to repeat check with NEW GENERATED NAME (i.e. name with date).
Then I think I'got the reason, then may be the fix can be quicker that I've thinked.


regards

(0023032)
Mr.Bricodage (updater)
2015-04-03 20:51

Confirmation about fman explanation (tested with TL 1.9.13) :
- import the first test case "Test" => OK
- import the second test case "Test" => Renamed "20150403-20:43:16" => OK
- import the third test case "Test" => Renamed "20150403-20:43:16" => OK

=> You see that 2nd and 3rd testcase have the same name.

When you try to edit 2nd or 3rd TestCase, Testlink see that the same name is already used when you try to save your modifications : "Name:20150403-20:43:16 Test already exists".
The solution is already provided by fman : "repeat check with NEW GENERATED NAME"
(0023037)
fman (administrator)
2015-04-04 07:36

https://github.com/TestLinkOpenSourceTRMS/testlink-code/commit/03f39bead04c343f74823b2a51ee01be8ca51723 [^]
(0023963)
fman (administrator)
2015-09-19 08:49

1.9.14 Padawan - released - 2015-09-19

- Issue History
Date Modified Username Field Change
2012-07-18 13:26 thomas.peters.al New Issue
2012-07-18 13:26 thomas.peters.al File Added: TestSuite-TL.xml
2012-07-18 17:52 fman Note Added: 0016985
2012-07-18 17:52 fman Assigned To => fman
2012-07-18 17:52 fman Status new => feedback
2012-07-19 06:33 thomas.peters.al Note Added: 0016987
2012-07-19 06:33 thomas.peters.al Status feedback => assigned
2012-07-19 06:33 thomas.peters.al File Added: Dup-TC-Import.jpg
2012-07-19 20:59 fman Note Added: 0016988
2012-07-19 21:04 fman Note Edited: 0016988 View Revisions
2015-04-03 20:51 Mr.Bricodage Note Added: 0023032
2015-04-04 07:35 fman Fixed in Version => 1.9.14 (2015 Q3)
2015-04-04 07:36 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2015-04-04 07:36 fman Note Added: 0023037
2015-04-04 07:36 fman Status assigned => resolved
2015-04-04 07:36 fman Resolution open => fixed
2015-04-04 07:36 fman Relationship added child of 0006830
2015-09-19 08:49 fman Note Added: 0023963
2015-09-19 08:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker