Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005086TestLinkAPI - XMLRPCpublic2012-07-10 23:432012-09-01 19:59
Reporterfast.chip 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0005086: "tl.getTestCaseIDByName" RPC API returned identical testcase with lowest internal id
DescriptionIn our setup we have more than one test suites containing identical testcase name e.g., "install package"
suite1
  -install_pkg
suite2
  -install_pkg

Unless the optional suite name was specified in the subject call it always returned the suite1/testid (that was created prior to) instead of suite2

Additional InformationTherefore the suite name in the call must set as mandatory to avoid inconsistent results.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon ppc.png [^] (5,762 bytes) 2012-07-11 20:02


png file icon ppc-results-test-1.png [^] (27,017 bytes) 2012-07-11 20:04

- Relationships

-  Notes
(0016962)
fman (administrator)
2012-07-11 17:35
edited on: 2012-07-11 19:25

>> Unless the optional suite name was specified in the subject call it always
>> returned the suite1/testid (that was created prior to) instead of suite2
System do the best can do, there is no right answer in this case, because not enough information was provided on function call to identify object.
If test case name has to be used then must be unique.

right now this sentence present on documentation seems not to be honored
>> No results will be returned if there are test cases with the same name that >>match the criteria provided.


IMHO, solution is:
when more of one match exists, then result has to include test case full 'path'.
Test suite can continue to be optional on call.

(0016966)
fman (administrator)
2012-07-11 20:02
edited on: 2012-07-11 20:05

Just tested on next release code (1.9.4)
Enviroment: see attached image (ppc.png)

tested with
http://localhost:8080/development/gitrepo/tlcode/lib/api/sample_clients/php/clientGetTestCaseIDByName.php [^]

result => see attached image, (ppc-results-test-1.png) multiple hits returned. OK

please provide your test case

(0017327)
fman (administrator)
2012-09-01 19:59

1.9.4 released

- Issue History
Date Modified Username Field Change
2012-07-10 23:43 fast.chip New Issue
2012-07-11 17:32 fman Description Updated View Revisions
2012-07-11 17:35 fman Note Added: 0016962
2012-07-11 19:25 fman Note Edited: 0016962 View Revisions
2012-07-11 20:02 fman Note Added: 0016966
2012-07-11 20:02 fman File Added: ppc.png
2012-07-11 20:04 fman Note Edited: 0016966 View Revisions
2012-07-11 20:04 fman File Added: ppc-results-test-1.png
2012-07-11 20:05 fman Note Edited: 0016966 View Revisions
2012-07-11 20:05 fman Assigned To => fman
2012-07-11 20:05 fman Status new => feedback
2012-07-14 07:27 fman Status feedback => resolved
2012-07-14 07:27 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-07-14 07:27 fman Resolution open => fixed
2012-09-01 19:59 fman Note Added: 0017327
2012-09-01 19:59 fman Status resolved => closed
2013-04-25 17:30 fman Category TL API => XMLRPC API
2013-04-25 17:30 fman Category XMLRPC API => API - XMLRPC



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker