Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005074TestLinkKeywordspublic2012-06-22 08:122012-09-01 19:59
ReporterAnne 
Assigned Tofman 
PriorityurgentSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0005074: Bulk Keyword assignment - All keywords are assigned to the test case instead of the selected keyword
DescriptionI assign keywords to T1 and T2 with using the link "assign keywords"
D1 (K1 - K2)
 T1 (K1)
 T2 (K2)
Then I assign a keyword to D1 (K3)
Then I have the following result
D1 (K1 - K2 -K3)
 T1 (K1 - K2 - K3)
 T2 (K1 - K2 - K3)
But I expect the following result
D1 (K1 - K2 -K3)
 T1 (K1 - K3)
 T2 (K2 - K3)
Steps To ReproduceI create a test suite with 2 tests
D1 (T1-T2)
I assign keywords to T1 and T2
D1 (K1 - K2)
 T1 (K1)
 T2 (K2)
Then I assign a keyword to D1 (K3)
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL: 5.1
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0004934closedfman Selective Assigment of Keywords to Test Suites 
has duplicate 0004883closedfman Lose of keywords at testcase levels 
has duplicate 0003554closedfman Assigning keywords to a Test Suite assigns all keywords in Assigned listbox 

-  Notes
(0016929)
fman (administrator)
2012-06-22 10:01

try to use common terms like Test Suite and Test case, there is not such thing as directory
(0016930)
Anne (reporter)
2012-06-22 11:32

All directory keywords are assigned to the test instead of the selected keyword
=> All Test suite keywords are assigned to the test case instead of the selected keyword

Directory for me = Test suite
Test for me = test case
(0016937)
fman (administrator)
2012-06-23 17:22

try to make a diff bewteen file available on commit and your files,
to generate the fixed version for 1.9.3
Retest and let us know:
http://gitorious.org/testlink-ga/testlink-code/commit/26e52c8b76cf1e0e08fff5413953853f7c5a4795 [^]
(0016940)
Anne (reporter)
2012-06-25 09:42

It is Ok with the update, but there is another defect
If I assign a keyword to a testSuite, and then I unassign the keyword to the test suite, then all testcase keywords are unassigned
(0016948)
fman (administrator)
2012-07-02 18:16

Please provide steps to reproduce
(0017332)
fman (administrator)
2012-09-01 19:59

1.9.4 released

- Issue History
Date Modified Username Field Change
2012-06-22 08:12 Anne New Issue
2012-06-22 10:01 fman Note Added: 0016929
2012-06-22 11:32 Anne Note Added: 0016930
2012-06-23 16:45 fman Summary [KeyWord assignation]All directory keywords are assigned to the test instead of the selected keyword => Bulk Keyword assignment - All keywords are assigned to the test case instead of the selected keyword
2012-06-23 17:22 fman Note Added: 0016937
2012-06-23 17:23 fman Tag Attached: TO BE FIXED on 2.0
2012-06-23 17:23 fman Assigned To => fman
2012-06-23 17:23 fman Status new => assigned
2012-06-23 17:37 fman Relationship added has duplicate 0004943
2012-06-23 17:37 fman Relationship deleted has duplicate 0004943
2012-06-23 17:38 fman Relationship added duplicate of 0004934
2012-06-23 17:39 fman Relationship added has duplicate 0004883
2012-06-23 17:40 fman Status assigned => feedback
2012-06-23 17:41 fman Relationship added has duplicate 0003554
2012-06-25 09:42 Anne Note Added: 0016940
2012-06-25 09:42 Anne Status feedback => assigned
2012-07-02 18:16 fman Note Added: 0016948
2012-07-07 14:51 fman Status assigned => resolved
2012-07-07 14:51 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-07-07 14:51 fman Resolution open => fixed
2012-09-01 19:59 fman Note Added: 0017332
2012-09-01 19:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker