Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005069TestLinkTest Execute - 'Save and move to next'public2012-06-18 14:252012-09-01 19:59
ReporterEvelin 
Assigned Tofman 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0005069: "Save and move to next" does not work when Execution feature is opened on a POP-UP window
DescriptionWe have a test installation of TestLink 1.9.3 Prague.
During test execution, I like to click Passed or Failed or whatever result, then click "Save and move to next" and test the TC that comes next in my list. This does not work. After I clicked "Save and move to next", the old test case is still shown, and the page or runner module or however you call it does not move to the next TC in the list.
Steps To Reproduce- Add test cases TC1 and TC2 to a test plan that has a build, and assign the tester
- Login as this tester and click the "Test cases assigned to me" link in Test Execution
- My table is sorted by builds, then by status (but this has no influence).
- Go to the section for the build. TC1 and TC2 are listed there, both with status "Not run".
- Click "Execute" (green gear wheel symbol) for TC1. Click "Passed" and "Save and move to next".
- Now, TC1 is still shown, with status "Passed". But this is not what I want. I like to read the next test case, test it and report the result.
Additional Informationsame as 0004724 which I cannot edit because it is closed
I can reproduce whenever I like, but I have no idea if it is a bug or just some crazy configuration problem.
TagsTO BE FIXED on 1.9.4 AND 2.0
Database (MySQL,Postgres,etc)MySQL
BrowserIE8
PHP Version5.3
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Fileszip file icon TestLink Config.zip [^] (21,427 bytes) 2012-06-18 14:25
png file icon save_and_move_to_next.png [^] (11,286 bytes) 2012-06-18 18:23


png file icon testspec.png [^] (15,590 bytes) 2012-06-18 18:32


gz file icon fix-5069.tar.gz [^] (24,149 bytes) 2012-06-18 21:18

- Relationships
has duplicate 0005088closedfman 'Save and move to next' doesn't work (when exec feature is called from 'Test Cases Assigned to Me' View. ) 

-  Notes
(0016904)
fman (administrator)
2012-06-18 15:17
edited on: 2012-06-18 15:19

This works on 1.9.4 when used this way

1. login
2. go to execute feature
3. select a test case inside a test suite that has more test cases that are SIBBLINGS of selectec test case

Important Notice:
this work ONLY INSIDE a test suite => if you two test suites (TS1, TS2) with 4 tc each, if you select TS1, save and next after reach LAST TC on TS1 will NOT CONTINUE with NEXT Test suite.

(0016905)
Evelin (reporter)
2012-06-18 15:25
edited on: 2012-06-18 15:27

1.9.4 is not yet released, right? We are in the middle of our evaluation and would like to test it.
What do you mean with siblings in this context?

(0016906)
fman (administrator)
2012-06-18 18:23
edited on: 2012-06-18 18:45

>> What do you mean with siblings in this context?
Give a look to attached image (save_and_move_to_next.png => the test plan)
ONLY all test cases that have same parent (example Test suite TS100.1) are siblings.
TS100.1 have 4 test cases, each test case on this test suite has 3 siblings.


I've done a fresh install on 1.9.3 got from sourceforge, create a test project with structure you can see on image (testspec.png), created a test plan, with one build.
Then go to execute feature using link on TL main screen.
Then click to TC2X INSIDE TS100.1, on right pane select blocked, then click on button Save and move to next, and right pane is updated and presented data regarding next test case QTC1A.
IMPORTANT NOTICE on tree on left side no test case node will be highlighted or selected.

I'm not able to reproduce any error.
>>> OK reproduced
Error is originated on $args->testcases_to_show EMPTY

(0016910)
fman (administrator)
2012-06-18 21:15

I can offer you this simple fix, use attached files and let us know.
Important thing:
if you have 4 test cases on test suite and JUST 3 assigned to you, you will also be able to access the 4 test cases when using save and move next.
(0016911)
Evelin (reporter)
2012-06-19 09:27

Great, I have replaced the files, and we can use the feature now (inside the restrictions you mentioned - we have further ideas to enhance the feature but they do not belong to a bug report).
Thanks a lot, fman.
(0016970)
piotrgrzybowski (reporter)
2012-07-13 06:59

Tried it with TestLink 1.9.3 (Prague) and it doesn't work for me. I still can't in pop-up window use "Save and move to next".
I have pasted the two files from your attachment.
(0016972)
fman (administrator)
2012-07-13 14:23

@piotrgrzybowski
fix has worked for Evelin,then you have to double check what you have done.
Issue will be set again to resolved.
(0017291)
fman (administrator)
2012-09-01 19:59

1.9.4 released

- Issue History
Date Modified Username Field Change
2012-06-18 14:25 Evelin New Issue
2012-06-18 14:25 Evelin File Added: TestLink Config.zip
2012-06-18 15:17 fman Note Added: 0016904
2012-06-18 15:19 fman Note Edited: 0016904 View Revisions
2012-06-18 15:25 Evelin Note Added: 0016905
2012-06-18 15:27 Evelin Note Edited: 0016905 View Revisions
2012-06-18 18:23 fman Note Added: 0016906
2012-06-18 18:23 fman File Added: save_and_move_to_next.png
2012-06-18 18:29 fman Note Edited: 0016906 View Revisions
2012-06-18 18:30 fman Note Edited: 0016906 View Revisions
2012-06-18 18:31 fman Note Edited: 0016906 View Revisions
2012-06-18 18:31 fman Note Edited: 0016906 View Revisions
2012-06-18 18:32 fman Note Edited: 0016906 View Revisions
2012-06-18 18:32 fman File Added: testspec.png
2012-06-18 18:35 fman Summary "Save and move to next" really does not work => "Save and move to next" does not work when Execution feature is opened on a POP-UP window
2012-06-18 18:37 fman Note Edited: 0016906 View Revisions
2012-06-18 18:45 fman Note Edited: 0016906 View Revisions
2012-06-18 18:49 fman Assigned To => fman
2012-06-18 18:49 fman Status new => assigned
2012-06-18 21:15 fman Note Added: 0016910
2012-06-18 21:18 fman File Added: fix-5069.tar.gz
2012-06-18 21:21 fman Status assigned => feedback
2012-06-19 09:27 Evelin Note Added: 0016911
2012-06-19 09:27 Evelin Status feedback => assigned
2012-06-23 17:26 fman Tag Attached: TO BE FIXED on 1.9.4 AND 2.0
2012-07-12 16:22 fman Relationship added has duplicate 0005088
2012-07-13 06:59 piotrgrzybowski Note Added: 0016970
2012-07-13 14:23 fman Note Added: 0016972
2012-07-13 14:23 fman Status assigned => resolved
2012-07-13 14:23 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-07-13 14:23 fman Resolution open => fixed
2012-08-16 12:28 fman Task Workflow Status => TBD
2012-08-16 12:28 fman Category Test Execute => Test Execute - 'Save and move to next'
2012-09-01 19:59 fman Note Added: 0017291
2012-09-01 19:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker