Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005050TestLinkTest Specificationpublic2012-06-04 18:452013-12-13 17:02
Reporterqvii 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.9 (2013 Q4 - bug fixing) 
Summary0005050: Search Test Cases - Add the ability to search based on author
DescriptionI would like the ability to search the test cases based on:
1)the author who created test case
2)the person that test case was last modified by.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserAll
PHP Version
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
duplicate of 0003701new Search filter for test cases should allow to search based on testcase creator 

-  Notes
(0016831)
fman (administrator)
2012-06-04 21:44

requrirement need details
1. how the author will be specified for search ?
combo box with all users with a role on test project ?
free text input ?

2. same question for last updater?
(0016839)
qvii (reporter)
2012-06-05 12:03

Sorry for the duplicate.

1) I would suggest using a dropdown list, listing the users alphabetically by login name, I think that would be the easiest to implement. If you wanted to give more detail, it could be login followed by a space, dash, space, the first name, space and then last name, e.g. "jdoe - John Doe"

If you did free form you could allow wildcard characters. For me personally, I dont need the wildcards, not sure what the general user base prefers.

2) Ditto
(0020205)
qvii (reporter)
2013-12-13 16:50

I think this can be closed due to the release of 1.9.9

- Issue History
Date Modified Username Field Change
2012-06-04 18:45 qvii New Issue
2012-06-04 21:44 fman Note Added: 0016831
2012-06-04 22:00 fman Relationship added duplicate of 0003701
2012-06-05 12:03 qvii Note Added: 0016839
2013-12-13 16:50 qvii Note Added: 0020205
2013-12-13 17:02 fman QA Team - Task Workflow Status => READY FOR TESTING
2013-12-13 17:02 fman Status new => resolved
2013-12-13 17:02 fman Fixed in Version => 1.9.9 (2013 Q4 - bug fixing)
2013-12-13 17:02 fman Resolution open => fixed
2013-12-13 17:02 fman Assigned To => fman
2013-12-13 17:02 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker