Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005046TestLinkRequirement Managementpublic2012-06-02 12:292012-06-09 16:02
Reporterdmereaux 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformFF 12.0OSMAC OSOS Version10.6.8
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version 
Summary0005046: Requirement coverage by configuration problem
DescriptionNot able to have coverage by platform.
Steps To ReproduceInitial state
One requirement is covered by 2 test case.
For the test plan 3 configurations have been defined : FF IE and Safari.
Test have been executed for FF and IE.

Coverage is updated only for last executed platform
eg : coverage for FF is ok and coverage for IE is set to not executed.
See screenshot
TagsNo tags attached.
Database (MySQL,Postgres,etc)My Sql
BrowserFF
PHP Version5.2.13
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon Screenshot.zip [^] (503,257 bytes) 2012-06-02 12:29

- Relationships

-  Notes
(0016824)
dmereaux (reporter)
2012-06-02 14:52

On 1.9.3 problem is same
(0016825)
fman (administrator)
2012-06-02 15:58

Please provide detailed steps to reproduce like

1. create test project
2. create test suite
3. create test case 1
4 ...
5 ...
(0016847)
dmereaux (reporter)
2012-06-09 15:52

1/ I create a test project named TP-AUTO
2/ I create several requirements and two under a directory named "fct"
3/ I create several 2 testcases to cover first requirement.
4/ I did the link between one requirement and newly created requirement
5/ Then I create a test plan names "plan1"
6/ I add the testcase and 3 configurations IE, Safari and FIREFOX.
7/ I create a build and run testcase under IE un Firefox (last one)
8/ I go to requirement report and select IE, tests are shown as not executed
9/ I go to requirement report and select FIREFOX, tests are shown as executed
10/ I run again the testcase under IE
11/ I go to requirement report and select IE, tests are shown as executed
12/ I go to requirement report and select FIREFOX, tests are shown as not executed
(0016848)
fman (administrator)
2012-06-09 16:02

thanks for details.
You will be informed automatically by Mantis, when we will have some news on this issue

- Issue History
Date Modified Username Field Change
2012-06-02 12:29 dmereaux New Issue
2012-06-02 12:29 dmereaux File Added: Screenshot.zip
2012-06-02 14:52 dmereaux Note Added: 0016824
2012-06-02 15:57 fman Product Version 1.9.2 (2011 Q2 - bug fixing) => 1.9.3 (2011 Q3 - bug fixing)
2012-06-02 15:58 fman Note Added: 0016825
2012-06-09 15:52 dmereaux Note Added: 0016847
2012-06-09 16:02 fman Note Added: 0016848



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker