Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005025TestLinkTest Specificationpublic2012-05-18 12:212014-07-27 10:17
ReporterKsaleki 
Assigned Tofman 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionreopened 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0005025: I can not create testcases ! IIS 7 , FastCGI with PHP Version 5.2.17 , MS SQL 2008
DescriptionProblems : i can not create testcases !
hope you can help me .
i installed IIS 7 , FastCGI with PHP Version 5.2.17 , MS SQL 2008
i can create Users, can see the complete GUI "pictures, CSS files" which means for me , that i have the correct folder permissions.

i created a Database named testlink and run the following scripts:
1) \testlink-1.9.3\install\sql\mssql\testlink_create_tables.sql
2) \testlink-1.9.3\install\sql\mssql\testlink_create_default_data.sql

My problem:
i can create a Project , a Plan, creat new user, give them roles ! i can creat a Testsuite.

BUT when i want to create a testcase for the testsuite i will get a timout !
HTTP Error 500.0 - Internal Server Error
C:\php\php-cgi.exe - The FastCGI process exited unexpectedly

Module
FastCgiModule

Notification
ExecuteRequestHandler
Handler
php-5.2.17

Error Code
0xc0000005

Requested URL
http://localhost:80/lib/testcases/tcEdit.php?containerID=3 [^]

Physical Path
C:\inetpub\wwwroot\lib\testcases\tcEdit.php

Logon Method
Anonymous

Logon User
Anonymous

Failed Request Tracing Log Directory
C:\inetpub\logs\FailedReqLogFiles

my phpinfo is showing mssql with alle the correct Configs:

[MSSQL]
mssql.allow_persistent = On
mssql.max_persistent = -1
mssql.max_links = -1
mssql.min_error_severity = 10
mssql.min_message_severity = 10
mssql.compatability_mode = Off
mssql.secure_connection = Off
mssql.connect_timeout = 5
mssql.timeout = 60
mssql.batchsize = 0
mssql.datetimeconvert = On

extension=php_mssql.dll

extension_dir = "C:\php\ext\"
upload_tmp_dir = "C:\inetpub\wwwroot\temp\"
open_basedir = "C:\inetpub\wwwroot\"
error_log = "C:\Windows\Temp\php-5.2.17_errors.log"
cgi.force_redirect = 0
cgi.fix_pathinfo = 1
fastcgi.impersonate = 1
html_errors = Off
fastcgi.logging = 0
TagsNo tags attached.
Database (MySQL,Postgres,etc)MSSQL
BrowserIE9
PHP Version5.2.17
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
related to 0005027closedfman table creation script for 'tcversions' missing column 'status' 
has duplicate 0005056closedfman Testlink installation is not working with MS SQL 2008 

-  Notes
(0016701)
Ksaleki (reporter)
2012-05-18 13:40

I have the same issue , with creating requirements !
(0016702)
Ksaleki (reporter)
2012-05-18 13:42
edited on: 2012-05-18 19:19

after I press the save button requirements, I get an error message. HTTP Error 500.0 - Internal Server Error
 C: \ php \ php-cgi.exe - The FastCGI process exited unexpectedly
modules
 FastCgiModule
 Notification
 ExecuteRequestHandler
 handler
 php-5.2.17
 Error Code
 0xc0000005

 requested URL
 http://localhost:80/lib/requirements/reqSpecEdit.php?doAction=create&tproject_id=1 [^]

 Physical Path
 C: \ inetpub \ wwwroot \ lib \ requirements \ reqSpecEdit.php

 Logon Method
 basic

 and then if I do not refresh it shows me the Req and Test Case

(0016705)
BillArnette (reporter)
2012-05-18 18:55

I had the same issue and found that the tcversions table in the database was missing a column.

Add the following column to the tcversions table:

        status smallint NOT NULL CONSTRAINT /*prefix*/[DF_tcversions_status] DEFAULT ((1)),
(0016706)
fman (administrator)
2012-05-18 19:14

MSSQL ADODB drivers provided with 1.9.3, when an error is found (like missing column) goes nuts.
(0016707)
fman (administrator)
2012-05-18 19:16
edited on: 2012-05-18 19:18

@Ksaleki
1. when adding issues please cleanup your text of unwanted blank lines
2. adding characters like ! => provide absolute no value => avoid

(0016718)
Ksaleki (reporter)
2012-05-21 07:56

Hi guys,
many sorry for writting mistakes ( spelling ! and so on )


i created the following Coloumn:

ALTER TABLE dbo.tcversions ADD status smallint default(1);


but it is not working :-( i have the same issue !
(0016719)
Ksaleki (reporter)
2012-05-21 08:02

ALTER TABLE dbo.tcversions ADD
    status smallint NOT NULL CONSTRAINT DF_tcversions_status DEFAULT ((1))

is not working , too
(0016720)
fman (administrator)
2012-05-21 09:07

have you checked all table definitions against MySQL scripts?
(0016724)
Ksaleki (reporter)
2012-05-21 09:10

i am working on it right now ! i printed the

"testlink-1.9.3\install\sql\mssql" out and compare it with the files of
"testlink-1.9.3\install\sql\mysql"
(0016729)
Ksaleki (reporter)
2012-05-21 09:47

its done , it was only a missed coloumn in tcversions called status

CREATE TABLE dbo.tcversions (
    id int NOT NULL,
    tc_external_id int NULL,
    version smallint NOT NULL DEFAULT ((1)),
    layout smallint NOT NULL DEFAULT ((1)),
    status smallint NOT NULL DEFAULT ((1)),
    summary text NULL,
    preconditions TEXT NULL,
    importance smallint NOT NULL DEFAULT ((2)),
    author_id int NULL,
    creation_ts datetime NOT NULL DEFAULT (getdate()),
    updater_id int NULL,
    modification_ts datetime NULL,
    active tinyint NOT NULL DEFAULT ((1)),
    is_open tinyint NOT NULL DEFAULT ((1)),
    execution_type tinyint NOT NULL DEFAULT ((1))
 CONSTRAINT /*prefix*/PK_tcversions PRIMARY KEY CLUSTERED
(
    id ASC
) ON [PRIMARY]
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY];


and we had a different order of the coloums in

.tcversions
.testplan_tcversions
.testprojects
.req_revisions
(0016731)
Ksaleki (reporter)
2012-05-21 09:52

the problem is still the same.

i push the create button for creating a testcase in a testsuite and it takes 2 minutes "to reach a timeout".

getting a HTTP Error 500.0 - Internal Server Error
FastCgiHandler
ExecuteRequestHandler
Requested URL :http://localhost:80/lib/testcases/tcEdit.php?containerID=9 [^]
Physical Path :C:\inetpub\wwwroot\lib\testcases\tcEdit.php


really strange behavior , because everything else like roles, testplan, project etc. is working pretty fine
(0016732)
fman (administrator)
2012-05-21 10:56

>> really strange behavior , because everything else like roles, testplan,
>> project etc. is working pretty fine
This means nothing, because we are talking of OTHER FEATURES

We will try to give a look but not in the next two week, we are busy with a difficult refactoring
(0016733)
Ksaleki (reporter)
2012-05-21 11:06

Many thanks in advance for your efforts!
(0016735)
Ksaleki (reporter)
2012-05-21 13:20

Mr. Fman,

it would be great , if i could use it in this week. my company will work with testlink and i will support you than with some benefits.
(0016737)
Ksaleki (reporter)
2012-05-21 14:20

Same Problem happens if I want to create

1. a Build under Test Execution.
2. Create ReQ
3. Click to Test Report


things which are working :

creating a Project
creating a testplan

Going to Events
Going to User Management and define userroles and order people to the roles.
Genrate Test Specs Documents
(0016738)
fman (administrator)
2012-05-21 14:20

@user
Do not expect any news on this issue on at LEAST one MONTH
(0016739)
fman (administrator)
2012-05-21 14:22

@user
stop adding info on this issue, if of NO HELP, just more noise
=> we are going to close it
(0016748)
Ksaleki (reporter)
2012-05-23 12:53

Sorry for that, I just want to help


now I have configured IIS 7 with MYSQL , everything works now.

in that sense, that is some problems with TestLink and MS SQL 2008 RC2 Express.
(0016749)
fman (administrator)
2012-05-23 17:53

@user
can you please clarify note 16748 ?

1. does TL now work OK ?
2. if answer to 1 is YES, please detail all changes / actions yo have done

3.what does this means
>> in that sense, that is some problems with TestLink and MS SQL 2008 RC2 Express.
that MSSQL2008 is the problem ?
(0016757)
Ksaleki (reporter)
2012-05-25 06:59

Hi,

to 1 and 2. TL works with IIS 7 installed PHP 5.2.17 and FastCGI as ModuleHandler, but only with MySQL for Windows.

If i switch the Database Connection to "MS SQL 2008 RC2 Express", than i will have timeout problems by:

creating testcases
creating builds
creating new Requirments
or clicking on Reports
(0016760)
2vpetrov (reporter)
2012-05-25 15:47

I found problem. If you locale not English then you can get error when testlink insert value in Datetime field, because it dateformat does not match with dateformat connection of MSSQL. For local correction, I adding next code in
lib\functions\database.class.php

    # return current timestamp for DB
    function db_now()
    {
        switch($this->db->databaseType)
        {
            /* @todo: maybe we should use this?
              case 'odbc_mssql':
                return "GETDATE()";
            */
            default:
                {
                  $this->db->SetDateLocale('RU'); /////////////
                  return $this->db->DBTimeStamp(time());
                }
        }
    }

And adding support Russian locale to function SetDateLocale.

I reccomend to install next value properties to MSSQL connection in MS SQL Management Tools

set quoted_identifier on
set arithabort off
set numeric_roundabort off
set ansi_warnings on
set ansi_padding on
set ansi_nulls on
set concat_null_yields_null on
set cursor_close_on_commit off
set implicit_transactions off
set language ???????
set dateformat dmy
set datefirst 1
set transaction isolation level read committed
(0016763)
fman (administrator)
2012-05-25 15:56

OK, but we need a real solution, may be a new parameter on config db file
to manage this.

Can you provide a cleaner solution ?
(0016765)
2vpetrov (reporter)
2012-05-25 16:54
edited on: 2012-05-25 16:55

You need initialize ado parameters fmtDate and fmtTimeStamp values that match locale MS SQL connection.

(0016843)
Ksaleki (reporter)
2012-06-07 20:19

any new news? how can I help to fix this issue?
(0016931)
Ksaleki (reporter)
2012-06-22 12:15

could anybody give me a workaround ? its really importing and i have no time anymore. i have to fix it in 2 weeks

- Issue History
Date Modified Username Field Change
2012-05-18 12:21 Ksaleki New Issue
2012-05-18 13:40 Ksaleki Note Added: 0016701
2012-05-18 13:42 Ksaleki Note Added: 0016702
2012-05-18 18:55 BillArnette Note Added: 0016705
2012-05-18 19:14 fman Note Added: 0016706
2012-05-18 19:16 fman Note Added: 0016707
2012-05-18 19:18 fman Description Updated View Revisions
2012-05-18 19:18 fman Note Edited: 0016707 View Revisions
2012-05-18 19:19 fman Note Edited: 0016702 View Revisions
2012-05-19 13:05 fman Status new => resolved
2012-05-19 13:05 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-05-19 13:05 fman Resolution open => fixed
2012-05-19 13:05 fman Assigned To => fman
2012-05-19 13:05 fman Relationship added related to 0005022
2012-05-19 13:05 fman Relationship deleted related to 0005022
2012-05-19 13:06 fman Relationship added related to 0005027
2012-05-21 07:56 Ksaleki Note Added: 0016718
2012-05-21 07:56 Ksaleki Status resolved => assigned
2012-05-21 07:56 Ksaleki Resolution fixed => reopened
2012-05-21 08:02 Ksaleki Note Added: 0016719
2012-05-21 09:07 fman Note Added: 0016720
2012-05-21 09:10 Ksaleki Note Added: 0016724
2012-05-21 09:47 Ksaleki Note Added: 0016729
2012-05-21 09:52 Ksaleki Note Added: 0016731
2012-05-21 10:56 fman Note Added: 0016732
2012-05-21 11:06 Ksaleki Note Added: 0016733
2012-05-21 12:14 Ksaleki Note Added: 0016734
2012-05-21 12:20 fman Note Deleted: 0016734
2012-05-21 13:20 Ksaleki Note Added: 0016735
2012-05-21 14:20 Ksaleki Note Added: 0016737
2012-05-21 14:20 fman Note Added: 0016738
2012-05-21 14:22 fman Note Added: 0016739
2012-05-23 12:53 Ksaleki Note Added: 0016748
2012-05-23 17:53 fman Note Added: 0016749
2012-05-25 06:59 Ksaleki Note Added: 0016757
2012-05-25 15:47 2vpetrov Note Added: 0016760
2012-05-25 15:56 fman Note Added: 0016763
2012-05-25 16:54 2vpetrov Note Added: 0016765
2012-05-25 16:55 2vpetrov Note Edited: 0016765 View Revisions
2012-06-07 20:19 Ksaleki Note Added: 0016843
2012-06-12 20:19 fman Relationship added has duplicate 0005056
2012-06-22 12:15 Ksaleki Note Added: 0016931
2014-07-27 10:17 fman Status assigned => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker