Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004989TestLinkReportspublic2012-04-29 14:052012-09-01 19:59
Reporterfman 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0004989: Reports - Overall Build Status - refactoring and final business logic.
DescriptionFor 1.9.4 ALL REPORTS regarding execution status are going to work this way:

1. figures will be computed using LATEST EXECUTION, considering ONLY TEST CASES that have tester assignment.

2. If you need to manage situation where you do not want/ you can not assign to a REAL specific user, then create a dummy user 'Firts Tester with free time' or 'Any tester on group', and assign to this user.
Additional InformationSuppose you have to test an artifact, and create a test plan with 1000 test cases.
You plan to create 4 releases (On TL this map to Build concept): 1.1,1.2,1.3,1.4.

For Release 1.1, you are going to run WHOLE Test plan contents, i.e. 1000 test cases.
On all reports total test case qty to be considered will be 1000.

After some work, your dev team has released Release/Build 1.2.
Due to some reason, you know you are going to run only 600 of 1000 test cases on Test plan.
You need that reports do not show a bias of 400 Not Run test cases (the set of test cases
you are not going to run).
More, you do not want to create a new test plan with only the effective 600 test cases to
be runned againts Release/Build 1.2.

How to solve this ?
During developing of 1.9.1 we faced this issue, and possible solutions were

OPTION 1. Refactor of 'test case test plan assignment' Feature, that was done for (Test plan, Platform),
adding a new level Build => (Test plan, Platform, Build).
We consider that these option, will make more complex the already complex GUI for creating
test plan content.

OPTION 2. Use value of attribute 'Tester assigned for execution', adding HERE the BUILD level.

Our Design choice was OPTION 2.
How do you use this new feature to solve the problem ?
Back to our example, you assign a tester ONLY for the 600 test cases you plan to run, leaving
UNASSIGNED the 400 test cases you plan to IGNORE.

On reports ONLY test cases with tester assigned will be consider => for Release/Build 1.2
total amount of Test cases will be 600 and NOT 1000.

Unfortunatelly, till release 1.9.4 we were not able to fix ALL REPORTS, then we are providing
some figures that work this way, and other that continue to work as was on TL version < 1.9.0
On 1.9.4 this will be fixed.
TagsNo tags attached.
Database (MySQL,Postgres,etc)ANY
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Files

- Relationships
has duplicate 0005003closedfman General Test Plan Metrics pass/fail/blocked numbers include unassigned test cases 

-  Notes
(0017318)
fman (administrator)
2012-09-01 19:59

1.9.4 released

- Issue History
Date Modified Username Field Change
2012-04-29 14:05 fman New Issue
2012-04-29 14:05 fman Status new => assigned
2012-04-29 14:05 fman Assigned To => fman
2012-05-04 20:01 fman Relationship added has duplicate 0005003
2012-07-28 15:08 fman Task Workflow Status => TBD
2012-07-28 15:08 fman Status assigned => resolved
2012-07-28 15:08 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-07-28 15:08 fman Resolution open => fixed
2012-09-01 19:59 fman Note Added: 0017318
2012-09-01 19:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker