Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000497TestLinkNew Featurepublic2006-09-21 18:182010-05-01 20:36
Reporterjoni_piter 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Fixed in Version1.9 Beta 2 
Summary0000497: It should be possible to design and execute test cases simultaneously
DescriptionAs Test experts say (Cem Kaner, for example) Test objective is not only finding defects, but gaining information about the product. Also, test technique "Exploratory Testing" consists on dinamically design the tests as the process evolves, because the tester is always gaining information about the product.
So what I would find very useful is being able to design the test and execute at the same time. Something like the current "Execute Tests" but with all fields editable.
Currently I use the following workaround: I have 2 browsers (on 2 different machines), with one I write the test specification and on the other I write the test execution result and notes. Very often what we write on notes should be on expected result, because we consider it a feature, although we could not predict it.
Additional Informationhttp://www.kaner.com/pdfs/GoodTest.pdf [^]
TagsNo tags attached.
Database (MySQL,Postgres,etc)
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
has duplicate 0002364closedfman Ability to edit a test case during execution 
related to 0000192closedfman User should be able to edit the test case while executing it 

-  Notes
(0002501)
fman (administrator)
2007-11-03 14:44

Feature to be discussed, need to be assigned a priority

- Issue History
Date Modified Username Field Change
2006-09-21 18:18 joni_piter New Issue
2007-01-22 03:36 schlundus Project Testlink 1.6.x => TestLink
2007-01-22 16:40 fman Status new => assigned
2007-01-22 16:40 fman Assigned To => fman
2007-02-26 16:12 fman Relationship added related to 0000192
2007-11-03 14:44 fman Note Added: 0002501
2009-04-21 16:32 fman Relationship added has duplicate 0002364
2009-04-21 16:33 fman Status assigned => resolved
2009-04-21 16:33 fman Fixed in Version => 1.9 (DEV)
2009-04-21 16:33 fman Resolution open => fixed
2010-05-01 20:36 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker