Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004896TestLinkRequirements Import - TL XML formatpublic2012-01-26 20:312012-09-20 21:43
Reporterdeamonyx 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0004896: XML Requirement Import with same title for differents Doc ID
DescriptionGUI offers to import requirements via XML file.
My file contains few requirements with the same title. An simplified XML example below and in attached file "ToImport.xml" :
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<requirements xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> [^]
    <requirement>
        <docid>DocRef-ID1</docid>
        <title>title of my requirement</title>
        <node_order>0</node_order>
        <description>my description</description>
        <status>F</status>
        <type>3</type>
        <expected_coverage>1</expected_coverage>
    </requirement>
    <requirement>
        <docid>DocRef-ID2</docid>
        <title>Deleted</title>
        <node_order>0</node_order>
        <description>Deleted requirement</description>
        <status>F</status>
        <type>3</type>
        <expected_coverage>0</expected_coverage>
    </requirement>
    <requirement>
        <docid>DocRef-ID3</docid>
        <title>Deleted</title>
        <node_order>0</node_order>
        <description>Deleted requirement</description>
        <status>F</status>
        <type>3</type>
        <expected_coverage>0</expected_coverage>
    </requirement>
</requirements>

I configure my import to consider requirement with the "same ID" as duplicated (and not with the same title, of course).
The GUI provide me the information "Skipped - Reason: Duplicated req name" for the third requirement.
It seems that the import function result is the same when I choose "consider same title as duplicated".
Steps To Reproduce1. Use the configuration provided below in a XML file. (see file ToImport.xml)
2. Import in an empty requirement document the XML file, choosing to consider requirement as duplicated if has the same docId (see "importButton.JPG" and "GUIimport.JPG" for details).
3.Look up the import result for the third requirement
Additional InformationMy problem seems to be explain here :
http://www.teamst.org/forum/viewtopic.php?f=11&t=6475&hilit=req+import&sid=5cb3632a305fa8fb0f5c165698ca8ee8 [^]

fman asked to open a bug here, but I didn't find any trace here...
TagsNo tags attached.
Database (MySQL,Postgres,etc)Any
Browser
PHP Version
TestCaseID
QA Team - Task Workflow StatusTBD
Attached Filesxml file icon ToImport.xml [^] (909 bytes) 2012-01-26 20:31
jpg file icon GUIimport.JPG [^] (18,690 bytes) 2012-01-26 20:31


jpg file icon importButton.JPG [^] (22,233 bytes) 2012-01-26 20:32

- Relationships

-  Notes
(0016303)
fman (administrator)
2012-01-27 19:54

Please:
can you try to do some search here removing STATUS filter ?
(0016587)
fman (administrator)
2012-04-14 17:48

please provide requested feedback
(0016629)
fman (administrator)
2012-05-02 18:10

@joedemachio
Please follow a simple rule, do not use an issue to report something similar.
This issue regards requirements import, your note talk about test cases.
Different items => differente procedures.
Please if you think you have found an issue regarding test case import, then open a new issue with right subject, very detailed steps to reproduce and a sample file.
To mantain issues integrity we are forced to delete your note
(0017311)
fman (administrator)
2012-09-01 19:59

1.9.4 released

- Issue History
Date Modified Username Field Change
2012-01-26 20:31 deamonyx New Issue
2012-01-26 20:31 deamonyx File Added: ToImport.xml
2012-01-26 20:31 deamonyx File Added: GUIimport.JPG
2012-01-26 20:32 deamonyx File Added: importButton.JPG
2012-01-27 19:54 fman Note Added: 0016303
2012-04-09 09:09 fman Description Updated View Revisions
2012-04-14 17:48 fman Note Added: 0016587
2012-04-14 17:48 fman Assigned To => fman
2012-04-14 17:48 fman Status new => feedback
2012-05-02 10:28 joedemachio Note Added: 0016625
2012-05-02 18:10 fman Note Added: 0016629
2012-05-02 18:10 fman Note Deleted: 0016625
2012-07-28 15:13 fman Task Workflow Status => TBD
2012-07-28 15:13 fman Status feedback => resolved
2012-07-28 15:13 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-07-28 15:13 fman Resolution open => fixed
2012-09-01 19:59 fman Note Added: 0017311
2012-09-01 19:59 fman Status resolved => closed
2012-09-20 21:43 fman Category Export/Import => Import Requirements - XML format
2013-11-24 18:50 fman Category Import Requirements - XML format => Requirements Import - TL XML format



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker