Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004884TestLinkReportspublic2012-01-20 09:042013-05-26 20:07
Reporterusu_pcastilla 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindows XPOS Version
Product Version1.9.1 (bug fixing) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004884: Requirement Specification Report duplicated
DescriptionWhen i show the report of requirement specification(If i have more of one req.), the contents of these documents are duplicated.
Steps To Reproduce1 - Created a new project.
Project -> Test project Management -> Create -> Enable Req. Features

2 - Created a Requirement Specifications
Project -> Requirement Specifications -> Created a new Req.

3 - Created 2 o more Requirement operations.
Project -> Requirement Specifications -> Created Requirement operations

4 - Created 1 SubDir of Requirement Specification
Project -> Requirement Specifications -> Select the new Req. Spec. -> Created Req. Spec.

5 - Show the Requirement Specification Reports(PROJECT)
Project -> Generate Requirement Spec. Documents -> Check ALL -> click in the project dir
Show fine the tree of requirement .

Tree of the project:

Table Of Contents

1. P_REQ : PACK_REQUIREMENT

REQ1 : Example one

REQ2 : Example two

1.1. SUB_P_REQ : EXAMPLE OF SUBDIR

SUBREQ1 : Example third


6 - Show the Requirement Specification Reports(Requirement Spec.)

Project -> Generate Requirement Spec. Documents -> Check ALL -> click in the req. spec. Dir.
If you have more of one requirement, show a duplicate of the rest of requirement.

Table Of Contents

1. P_REQ : PACK_REQUIREMENT

REQ1 : Example one

REQ2 : Example two

1.1. SUB_P_REQ : EXAMPLE OF SUBDIR

SUBREQ1 : Example third

REQ2 : Example two

2. SUB_P_REQ : EXAMPLE OF SUBDIR

SUBREQ1 : Example third
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Fileszip file icon bug_testlink.zip [^] (22,441 bytes) 2012-01-20 09:04

- Relationships

-  Notes
(0016272)
fman (administrator)
2012-01-20 10:51

update to 1.9.3 and retest
(0016274)
usu_pcastilla (reporter)
2012-01-20 13:03

Thanks very much!. With the upgrade 1.9.3 it was fixed.
(0016276)
fman (administrator)
2012-01-20 13:55

OK, be careful that 1.9.3 is have also other issues, then before reporting give a look to Mantis

- Issue History
Date Modified Username Field Change
2012-01-20 09:04 usu_pcastilla New Issue
2012-01-20 09:04 usu_pcastilla File Added: bug_testlink.zip
2012-01-20 10:51 fman Note Added: 0016272
2012-01-20 10:52 fman Assigned To => fman
2012-01-20 10:52 fman Status new => feedback
2012-01-20 13:03 usu_pcastilla Note Added: 0016274
2012-01-20 13:03 usu_pcastilla Status feedback => assigned
2012-01-20 13:55 fman Note Added: 0016276
2012-01-20 13:55 fman Status assigned => resolved
2012-01-20 13:55 fman Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2012-01-20 13:55 fman Resolution open => fixed
2013-05-26 20:07 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker