Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004796TestLinkTest Specificationpublic2011-11-05 12:012013-06-05 07:17
Reporterfman 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0004796: Test Case reuse - Quick & Dirty Approach
Descriptionbased on implementation on requirements internal links, Test case reuse is proposed this way:

add following URL on any place you want of test case (summary, precond, etc)

javascript:openTCW(TESTCASE_EXTERNALID,TESTCASE_VERSIONNUMBER);

Example:
suppose you have test project 'Yellow submarine' with test case prefix 'YLS'.
Create Test Suite TSS-01
Create several common test cases
YLS-1 - Login Common Steps
YLS-2 - Logout Common Steps

Then you want to create TSS-02 with
YLS-3 bla bla
YLS-4 bla bla

you need a test case that is IDENTICAL to YLS-2, version 3 what to do ?
simple create YLS-5 and inside summary put

javascript:openTCW('YLS-2',3);


If you are using Web Rich editor need to insert a link with text you like ,
example: Test Case Reference

and this contents:
javascript:openTCW('YLS-2',3)


IMPORTANT NOTICE
You can also 'point' to a test case that belongs to ANOTHER Test Project


Tags16161, Test Case Reuse
Database (MySQL,Postgres,etc)N/A
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon TC-reuse-1.png [^] (17,375 bytes) 2011-11-05 18:35


png file icon TC-reuse-2.png [^] (12,734 bytes) 2011-11-05 18:35


png file icon TC-reuse-3.png [^] (16,522 bytes) 2011-11-05 18:35


png file icon TC-reuse-4.png [^] (69,998 bytes) 2011-11-05 18:36


png file icon TC-reuse-5.png [^] (25,365 bytes) 2011-11-05 18:36

- Relationships
related to 0004842closedfman Test Case search - add check of user rights 
parent of 0004637closedfman Copy of test steps 
related to 0001202acknowledged Test-case dependency 
related to 0004191closedfman linking testcases to one another to build scenarios (for reusability) 
related to 0005322closedfman Link to another test case via ID within TestLink (test case reuse) 

-  Notes
(0015959)
fman (administrator)
2011-11-05 13:39
edited on: 2011-11-05 18:38

Head
http://gitorious.org/testlink-ga/testlink-code/commit/d374c62119d8658586f4c8666ce8b019c93987b2 [^]

1.9.x
http://gitorious.org/testlink-ga/testlink-code/commit/de63e030d1e752d298e34770dd8619d5d42f1bf3 [^]

(0016159)
fman (administrator)
2011-12-17 18:38

Reopened due to TL role system issue.
A check has to be done in order to apply user rights before displaying test case.
Right now user can see info of Test Cases that belong to a test project where user has NO RIGHT grant => KO
(0016161)
fman (administrator)
2011-12-18 11:15

apply also

1.9.x
http://gitorious.org/testlink-ga/testlink-code/commit/204df745835151b73840f2d00a77bca2156f5b4c [^]
(0016300)
germanocosta (reporter)
2012-01-27 13:28

I use Testlink version 1.9.3. I do not know well PHP language, but, I do some changes. How can I implement this feature on my version?
(0016302)
fman (administrator)
2012-01-27 19:28

you have to get code from gitorious commits (notes 015959 and 16161) and compare with 1.9.3, adding missing parts.
Is not as hard as can seem
(0016314)
germanocosta (reporter)
2012-01-31 17:46

I did this, but there are a lot of differences. Is there any problem if I simply replace my Testlink files by gitorious' (only the files mentioned in notes 015959 and 16161)? Or I have to replace all files?
(0016315)
fman (administrator)
2012-02-01 17:34

you have to do as explained on note 16302
(0017348)
fman (administrator)
2012-09-01 19:59

1.9.4 released
(0018610)
fman (administrator)
2013-03-31 19:22

CRITIC:
with CKeditor 3.6.x you need to use Javascript: because javascript:
generates message => Invalid value

- Issue History
Date Modified Username Field Change
2011-11-05 12:01 fman New Issue
2011-11-05 12:02 fman Tag Attached: Test Case Reuse
2011-11-05 12:09 fman Relationship added parent of 0004637
2011-11-05 12:11 fman Relationship added related to 0001202
2011-11-05 13:39 fman Note Added: 0015959
2011-11-05 17:39 fman Description Updated View Revisions
2011-11-05 17:40 fman Description Updated View Revisions
2011-11-05 17:41 fman Description Updated View Revisions
2011-11-05 17:43 fman Description Updated View Revisions
2011-11-05 17:45 fman Description Updated View Revisions
2011-11-05 17:45 fman Description Updated View Revisions
2011-11-05 17:46 fman Description Updated View Revisions
2011-11-05 17:46 fman Description Updated View Revisions
2011-11-05 18:35 fman File Added: TC-reuse-1.png
2011-11-05 18:35 fman File Added: TC-reuse-2.png
2011-11-05 18:35 fman File Added: TC-reuse-3.png
2011-11-05 18:36 fman File Added: TC-reuse-4.png
2011-11-05 18:36 fman File Added: TC-reuse-5.png
2011-11-05 18:38 fman Note Edited: 0015959 View Revisions
2011-11-05 18:39 fman Assigned To => fman
2011-11-05 18:39 fman Status new => assigned
2011-11-11 19:41 fman Status assigned => resolved
2011-11-11 19:41 fman Fixed in Version => 2.0 (planned)
2011-11-11 19:41 fman Resolution open => fixed
2011-12-17 17:56 fman Description Updated View Revisions
2011-12-17 18:36 fman Status resolved => new
2011-12-17 18:38 fman Note Added: 0016159
2011-12-18 11:15 fman Note Added: 0016161
2011-12-18 11:18 fman Relationship added related to 0004842
2011-12-21 21:51 fman Relationship added related to 0004191
2012-01-27 13:28 germanocosta Note Added: 0016300
2012-01-27 19:28 fman Note Added: 0016302
2012-01-31 17:46 germanocosta Note Added: 0016314
2012-02-01 17:34 fman Note Added: 0016315
2012-04-09 09:07 fman Status new => assigned
2012-04-09 09:07 fman Product Version => 1.9.3 (2011 Q3 - bug fixing)
2012-04-09 09:07 fman Fixed in Version 2.0 (planned) => 1.9.4 (2012 Q3 - bug fixing)
2012-04-09 09:07 fman Status assigned => resolved
2012-09-01 19:59 fman Note Added: 0017348
2012-09-01 19:59 fman Status resolved => closed
2012-11-05 11:32 fman Relationship added related to 0005322
2013-03-31 19:22 fman Note Added: 0018610
2013-06-05 07:17 ohenneberg Tag Attached: 16161



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker