Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004722TestLinkImport results XML formatpublic2011-08-25 16:552014-09-27 16:43
Reporterthomas.montagne 
Assigned Tofman 
PrioritynormalSeverityfeature requestReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.12 (2014 Q3) 
Summary0004722: Importing custom field values during test results import
DescriptionI've created some custom fields affected to test executions, like "Duration".

I would like to be able to automatically import the test duration within XML execution results file.

I didn't found any way to do it, neither in documentation nor release notes.
Steps To Reproduce- Create a custom field, activated on "Test Execution"
- Create some tests
- Go to Test Execution
==> you can see your custom fieldjuste before the test result : GREAT
- Try to import test execution in XML file
==> no way to set the custom field value within the XML file.
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
BrowserMozilla Firefox 6.0
PHP Version5.3
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files

- Relationships
has duplicate 0006451closedfman FEATURE REQUEST - Importing custom fields in in test execution 
child of 0006457closedfman Availables hot-fixes for 1.9.11 & How To get full fixed package from gitorious 

-  Notes
(0020174)
ntr (reporter)
2013-12-09 16:23
edited on: 2013-12-09 16:31

I've solved this lack (importing a duration from xml) by changing some items in a php file.

I should tell that I'm not dealing with custom fields import.
I'm dealing with duration import through xml files, using the duration field that exists in the DB.
This field is present when setting a result manually in testlink : Execute tests from main screen -> Select a test -> Go at the end of the page (right panel) to get the white box called 'Result'. Here you can set the result of your testcase, but the duration too.

Now, here is my contribution to do it automatically when importing a result through an xml file. You need to modify the following file :
</lib/results/resultsImport.php>
Line 442:
" tcversion_id, execution_ts, notes, tcversion_number, platform_id, execution_type, execution_duration)" // added execution_duration - please check syntax since I've entered it manually from paper, not by copy/paste !

Line 445 :
"{$context->platformID},{$tcase_exec['execution_type']}, {$tcase_exec['duration']})"; // added {$tcase_exec['duration']} - check syntax

Line 537 :
$execInfo['duration']=(string)trim($xmlTCExec->duration); //added whole line - check syntax


I hope my contribution is good and will help you.

(0020178)
fman (administrator)
2013-12-09 20:26

I appreciate your help but IMHO you are not understanding well how things work.
If this issue is about IMPORTING CUSTOM FIELDS then you have to provide a solution to IMPORT ANY KIND OF CUSTOM FIELDS, or you are not providing a solution but just creating confusion

Do not VAMPIRIZE ISSUES, open a new issue with clear summary, details, steps to reproduce and potential solution.
(0020179)
ntr (reporter)
2013-12-10 10:26

OK fman, I've created a dedicated issue.
Please check issue 6087.
(0021748)
fman (administrator)
2014-09-27 16:43

Release done

- Issue History
Date Modified Username Field Change
2011-08-25 16:55 thomas.montagne New Issue
2011-08-29 16:32 fman Severity minor => feature request
2013-12-09 16:23 ntr Note Added: 0020174
2013-12-09 16:26 ntr Note Edited: 0020174 View Revisions
2013-12-09 16:26 ntr Note Edited: 0020174 View Revisions
2013-12-09 16:27 ntr Note Edited: 0020174 View Revisions
2013-12-09 16:29 ntr Note Edited: 0020174 View Revisions
2013-12-09 16:30 ntr Note Edited: 0020174 View Revisions
2013-12-09 16:31 ntr Note Edited: 0020174 View Revisions
2013-12-09 20:26 fman Note Added: 0020178
2013-12-10 10:26 ntr Note Added: 0020179
2014-07-28 20:35 fman Relationship added has duplicate 0006451
2014-07-28 20:36 fman QA Team - Task Workflow Status => TBD
2014-07-28 20:36 fman Category Test Execute => Import results XML format
2014-07-30 07:06 nganesan Note Added: 0021366
2014-07-30 12:41 fman Note Deleted: 0021366
2014-07-30 12:56 nganesan Note Added: 0021369
2014-07-31 21:44 fman Note Deleted: 0021369
2014-08-02 09:01 fman QA Team - Task Workflow Status TBD => READY FOR TESTING
2014-08-02 09:01 fman Status new => resolved
2014-08-02 09:01 fman Fixed in Version => 1.9.12 (2014 Q3)
2014-08-02 09:01 fman Resolution open => fixed
2014-08-02 09:01 fman Assigned To => fman
2014-08-02 09:02 fman Relationship added child of 0006457
2014-09-27 16:43 fman Note Added: 0021748
2014-09-27 16:43 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker