Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004715TestLinkTest Plan (builds, milestones, test assign)public2011-08-22 08:072012-09-01 20:00
Reporterbognar 
Assigned Tofman 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0004715: can_remove_executed = DISABLED doesn't work when Platforms are used. Test Cases can be removed
DescriptionThe can_remove_executed = DISABLED; setting doesn't forbid the executed TestCases deletion from TestPlan WHEN PLATFORMS ARE USED. Executed TCs can be marked for deletion and deleted by clicking on the [Add / Remove selected] button.
Steps To ReproducePreconditions:
- TestLink is set to $tlCfg->testcase_cfg->can_remove_executed = DISABLED;
- Exist: Testproject -> Testplan TP1 -> Build B1, Platform P1, Test Case TC1

1. Add the TC1 to TP1 execution, for build B1, Platform P1
2. Execute the TC1 with any result
3. Go back to the "Add / Remove Test Cases" screen and enable the checkbox for deletion from TP1
4. Click on the [Add / Remove selected] button
--> the TC1 is removed from TP1
Additional InformationAttached image shows screenshot from the Add/Remove TCs screen, cursor is hovering the lightning icon, tooltip says "Executed test cases can not be removed."
TagsTO BE FIXED on 2.0
Database (MySQL,Postgres,etc)MySQL
BrowserFirefox
PHP Version5.3.3
TestCaseID
QA Team - Task Workflow Status
Attached Filespng file icon Testlink-Disable_TC_remove-tooltip.png [^] (6,650 bytes) 2011-08-22 08:07


gz file icon planAddTC_m1.tpl.gz [^] (5,474 bytes) 2011-08-23 14:34

- Relationships

-  Notes
(0015734)
fman (administrator)
2011-08-22 21:18

Reminder sent to: Julian

@julian: can you do some checks ?
(0015745)
fman (administrator)
2011-08-23 14:34

@user:
try with attached file.
After replacing existing file with this, clean up templates_c dir, and browser cache
retest and let us know.
(0015746)
fman (administrator)
2011-08-23 14:35

1.9
http://gitorious.org/testlink-ga/testlink-code/commit/b16f4333b5bf64469c8431860c10d7025d7f18c0 [^]

http://gitorious.org/testlink-ga/testlink-code/commit/f8ac78747bb042acef640aa6c27c3f802fd051d0 [^]
(0015749)
bognar (reporter)
2011-08-24 06:33

I did as requested, the fix seems to help. The checkbox is NOT showed for specific platform anymore, if the TC has been executed on it.
Also rechecked with can_remove_executed = ENABLED - the checkbox is there always (as intended).

Thank you for quick reply and fix.
(0015751)
Julian (reporter)
2011-08-24 09:15

Fix works.
Minor fix necessary that caused "lightning" icon to not be shown when no platforms are used:

1.9
http://gitorious.org/testlink-ga/testlink-code/commit/490fdeba68b62669a638dba50cb6b40c2b686e81 [^]
(0017368)
fman (administrator)
2012-09-01 20:00

1.9.4 released

- Issue History
Date Modified Username Field Change
2011-08-22 08:07 bognar New Issue
2011-08-22 08:07 bognar File Added: Testlink-Disable_TC_remove-tooltip.png
2011-08-22 21:18 fman Note Added: 0015734
2011-08-23 14:14 fman Summary can_remove_executed = DISABLED doesn't work, Test Cases can be removed => can_remove_executed = DISABLED doesn't work when Platforms are used. Test Cases can be removed
2011-08-23 14:14 fman Description Updated View Revisions
2011-08-23 14:34 fman Note Added: 0015745
2011-08-23 14:34 fman File Added: planAddTC_m1.tpl.gz
2011-08-23 14:35 fman Note Added: 0015746
2011-08-23 14:35 fman Assigned To => fman
2011-08-23 14:35 fman Status new => feedback
2011-08-24 06:33 bognar Note Added: 0015749
2011-08-24 06:33 bognar Status feedback => assigned
2011-08-24 09:14 fman Status assigned => resolved
2011-08-24 09:14 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2011-08-24 09:14 fman Resolution open => fixed
2011-08-24 09:15 Julian Note Added: 0015751
2011-08-24 09:16 Julian Tag Attached: TO BE FIXED on 2.0
2011-09-03 14:34 fman Tag Detached: TO BE FIXED on 2.0
2011-09-03 14:40 fman Tag Attached: TO BE FIXED on 2.0
2012-09-01 20:00 fman Note Added: 0017368
2012-09-01 20:00 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker