Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004710TestLinkFilterspublic2011-08-18 07:572012-09-01 19:58
Reportergunter 
Assigned Tofman 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS VersionV-Server 2003
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0004710: Performance/Filter Problem on big project
DescriptionMaybe there are 2 problems, but at the moment i believe they have their reason in the same area. The problems begun with the update to 1.9.1.
Maybe it depends on the new enhancements for builds and results by tester per build.
1. Problem is, the reports are very slow or will completely not work (only white screen) "General Test Plan Metrics" and "Results by Tester per Build"
2. Problem is, when i go to section "Add / Remove Test Cases " and click on a child testsuite in the tree on the left site, it doesn't matter how much tc's are in the testsuite, the complete memory will be used an then i get an error message:
Fatal error: Out of memory (allocated 1872494592) (tried to allocate 5 bytes) in D:\htdocs\testlink\third_party\adodb\adodb.inc.php on line 1026
Steps To ReproduceThe db has 9 Projects and the Project with the most problems has a
Testspec with 2127 TC's in 29 Parent Test suites and a lot of child suites.
This project has 34 Testplans. The critical Plan has 919 TC's and 30 builds.
All Builds are assigned to the same user.
G
Additional InformationApache/2.2.19 (Win32) PHP/5.3.6
MySQL client version: mysqlnd 5.0.8-dev - 20102224 - $Revision: 308673 $
PHP extension: mysqli

Problem was also on a Linux server please look:
http://www.teamst.org/forum/viewtopic.php?f=11&t=4087&sid=3f93509a631d69dd30f51c996458c92a [^]
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL Server 5.5.14 / MyISAM
BrowserFirefox 3.6.20
PHP Version5.3.6
TestCaseID
QA Team - Task Workflow StatusREADY FOR TESTING
Attached Files? file icon TestlinkMemory.bmp [^] (3,007,062 bytes) 2011-08-18 07:57

- Relationships
child of 0004905closedfman Test Case Tester Assignment - filters dont work properly for 'Assigned to' Field 

-  Notes
(0015707)
fman (administrator)
2011-08-18 08:17

I do not remember if I have asked for this and then (sometimes happens due to other work) did nothing.
Can you give me access to d dump (zipped) of your db?
Please before doing this dump truncate events and transaction tables.
(0015719)
sdemelis (reporter)
2011-08-19 17:25

It's not only a problem of builds. I have the same issue for the "General Test Plan Metrics" using only 3 builds, but with 33 platforms.
In my case, the problem seems the size of the matrix "Executed test cases" and Platforms.
Here's the test I executed: 1 test plan, 3 builds, 620 test cases and 33 platforms. I executed about 200 test cases per platform:
- no issue for the report "General Test Plan Metrics" if test cases are not executed.
- no crash after 200 test cases executed for 24 different platforms, but the report is slower after each platform "affected" by executed test cases
- white screen or php memory error (the current setting for the memory is 2Gb) when I executed 200 test cases for the platform 25.
(0015724)
fman (administrator)
2011-08-20 08:41

@sdemelis
Please as has been done by gunter, help us providing you DB. (dump on big file, zipped, before doing dump please TRUNCATE events and transactions tables)
send an email to francisco.mancardi@gmail.com
(0015725)
fman (administrator)
2011-08-20 08:48

@gunter
I've seen strange thing on execution feature, all your test cases display on exec history 'Test Case version 0'.
If I execute on test case, then test case version have the right value
any hint ?
(0015726)
gunter (reporter)
2011-08-22 06:33

@fman
this could be due to the fact that we normally do not use the manual execution.
We have an self-written interface to our automated test protocol database. And this interface is doing the execution. It copy's the infos from the protocol db to testlink and it set's the execution. Do you think there is the bug?
(0015747)
fman (administrator)
2011-08-23 14:39

@gunter
regarding 0 in test case version, is up to you understand that this in not normal TL behaviour.

I've done an important refactoring to solve your issue, this means that can not give you a simple solution that work on 1.9.3.
Good new is that we plan to release 1.9.4 that will fix your issues during september.
(0015966)
paulewog (reporter)
2011-11-09 18:15

I also have the 'crash'/out of memory issue (I even tried giving the script 1024mb). Is 1.9.4 due out anytime soon?

I'm looking at the git repo and will try seeing if I can patch it myself...

It also has problems with query metrics if requesting all executions and not last-result-only.
(0015968)
fman (administrator)
2011-11-09 18:32

there is no release date for 1.9.4, but you can use patches we have provided here in form of link to git repo.

results and report is an area where we need to do lot of improvements
(0015969)
paulewog (reporter)
2011-11-09 18:34

maybe I am blind, I don't see any git repo links :)
- Paul
(0015970)
fman (administrator)
2011-11-09 18:39
edited on: 2011-11-09 18:39

My fault keep private note
APPLY IN THIS ORDER
1.9.
http://gitorious.org/testlink-ga/testlink-code/commit/af81ad4b4758694cf4d2c3a8100b882d533d3e44 [^] [^]

http://gitorious.org/testlink-ga/testlink-code/commit/765ca6126a087de487051fddd74c0d166aca39d5 [^] [^]

http://gitorious.org/testlink-ga/testlink-code/commit/2fe19c4b63d345167a6c775d58dcf4e2cec07d89 [^] [^]

(0015971)
paulewog (reporter)
2011-11-09 18:40

cool, thanks!
- Paul
(0015972)
paulewog (reporter)
2011-11-09 19:04

Do you happen to know how much improvement these changes make? I'm still having massive memory amounts being used (trying now by allowing the php script 2048mb...)
(0015973)
fman (administrator)
2011-11-09 20:07

have no figures, but improvement was noticiable.
do not remember how many test project, test cases etc.

what are caracteristics of your installation ? (how many test projects, test cases, builds, executions etc)
(0015974)
paulewog (reporter)
2011-11-09 20:21

We have 5 projects, 2337 testcase versions, and about 17,500 executions in total. With the project I'm trying to run reports on specifically, we have:

* 14 builds
* 712 test specifications
* About 200 tests per platform (ranges from 150 to 330)
* 22 platforms
* 6808 executions on this project

It looks like the original bug report was against a larger setup.

I will double check to make sure I have the right code in comparison to the commits...
(0015975)
fman (administrator)
2011-11-10 10:37

can you provide me the DB ?
(0017288)
fman (administrator)
2012-09-01 19:58

1.9.4 released

- Issue History
Date Modified Username Field Change
2011-08-18 07:57 gunter New Issue
2011-08-18 07:57 gunter File Added: TestlinkMemory.bmp
2011-08-18 08:17 fman Note Added: 0015707
2011-08-19 17:25 sdemelis Note Added: 0015719
2011-08-20 08:41 fman Note Added: 0015724
2011-08-20 08:48 fman Note Added: 0015725
2011-08-20 14:38 fman Relationship added related to 0004714
2011-08-22 06:33 gunter Note Added: 0015726
2011-08-23 14:39 fman Note Added: 0015747
2011-11-09 18:15 paulewog Note Added: 0015966
2011-11-09 18:32 fman Note Added: 0015968
2011-11-09 18:34 paulewog Note Added: 0015969
2011-11-09 18:39 fman Note Added: 0015970
2011-11-09 18:39 fman Note Edited: 0015970 View Revisions
2011-11-09 18:40 paulewog Note Added: 0015971
2011-11-09 19:04 paulewog Note Added: 0015972
2011-11-09 20:07 fman Note Added: 0015973
2011-11-09 20:21 paulewog Note Added: 0015974
2011-11-10 10:37 fman Note Added: 0015975
2012-05-15 04:23 asimon Relationship added child of 0004905
2012-08-16 12:39 fman Assigned To => fman
2012-08-16 12:39 fman Status new => assigned
2012-08-16 12:39 fman Task Workflow Status => READY FOR TESTING
2012-08-16 12:39 fman Status assigned => resolved
2012-08-16 12:39 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2012-08-16 12:39 fman Resolution open => fixed
2012-09-01 19:58 fman Note Added: 0017288
2012-09-01 19:58 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker