Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000047Testlink 1.6.xUser Managementpublic2005-08-16 17:082005-08-17 08:59
Reporteruser23 
Assigned Tofman 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version1.5.1 
Fixed in Version 
Summary0000047: Unable to Login
DescriptionGuys,
I just downloaded and installed testlink 1.5.1. After setup i was not able to login. After hours of going thru the code i realised that if ($userInfo && $userInfo[0] == md5($pwd)) was the culprit. Im not sure whether this piece of code has been tested, but userInfo[0] return the primary key to the record and not the password. the password is available in userInfo[2].

Regards
Ajay
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000020)
user23
2005-08-16 21:09

Alright, looks like the code was good but the SQl script was screwed up. there are two sets of sql and they both create the users table differently.
(0000021)
schlundus (reporter)
2005-08-17 08:52

Yes dont use testlink_new.sql

Looking at the table definition
--schnapp--
DROP TABLE IF EXISTS `user`;
CREATE TABLE `user` (
  `password` varchar(32) NOT NULL default '',
  `login` varchar(30) NOT NULL default '',
  `id` int(10) unsigned NOT NULL auto_increment,
....
--schnapp---
and the SQL query
--"SELECT * FROM user,rights
password should be at userinfo[0]
(0000022)
schlundus (reporter)
2005-08-17 08:59

Closed as Invalid

- Issue History
Date Modified Username Field Change
2005-08-16 17:08 user23 New Issue
2005-08-16 20:10 fman Status new => assigned
2005-08-16 20:10 fman Assigned To => fman
2005-08-16 21:09 user23 Note Added: 0000020
2005-08-17 08:52 schlundus Note Added: 0000021
2005-08-17 08:59 schlundus Note Added: 0000022
2005-08-17 08:59 schlundus Status assigned => closed
2005-08-17 08:59 schlundus Resolution open => no change required



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker