Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004696TestLinkTest Plan (builds, milestones, test assign)public2011-08-10 09:422012-09-01 20:00
ReporterJulian 
Assigned ToJulian 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.3 (2011 Q3 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0004696: Create Test Plan from existing Test Plan does not preserve linked Test Case Versions (keep currently linked version is checked)
DescriptionCreate Test Plan from existing Test Plan does not preserve linked Test Case Versions
Steps To Reproduce1. Create Test Plan "Plan1"
2. Create Test Case "TC1"
3. link Version 1 of "TC1" to "Plan1"
4. Click on Main Page -> Show Test Cases Newest Versions
5.1 Create Test Plan "Plan2"
5.2 Choose "Plan1" for "Create from existing Test Plan?"
5.3 Check Radio button "Current linked version"
6. Choose Test Plan "Plan2"
7. Click on Main Page -> Show Test Cases Newest Versions

Actual Result:
4. Newer version for TC1 is shown
7. No newer version is shown -> TC1 v2 is linked to "Plan2"

Expected Result:
7. Newer version for TC1 is shown -> TC1 v1 is linked to "Plan2"

Workaround:
1. Export Test Plan "Plan1"
2. Create Test Plan "Plan2" without creating from existing Test Plan
3. Import "Plan1" for "Plan2"
-> linked version is considered in this case
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files? file icon testplan.class.php [^] (156,403 bytes) 2011-08-10 10:33

- Relationships

-  Notes
(0015647)
Julian (reporter)
2011-08-10 10:32

Reminder sent to: fman

Could you give a quick look to attached fix ?
Think fix is ok but would like your opionion.
(0015698)
fman (administrator)
2011-08-17 20:27

Think is ok, you can commit
Just two things

1. add on file header
@since 1.9.4
ADD HERE COMMENT REGARDING THIS ISSUE
pleas use TICKET instead of BUGID

@since 1.9.3
(0015704)
Julian (reporter)
2011-08-18 06:26

Fixed for Branch 1.9:
https://gitorious.org/testlink-ga/testlink-code/commit/661d4a95c69d0594a827f30c58f68a89b9242686 [^]

and Master:
https://gitorious.org/testlink-ga/testlink-code/commit/be12499c0f5022b944aeb33c9619f36fbd0886d2 [^]
(0017372)
fman (administrator)
2012-09-01 20:00

1.9.4 released

- Issue History
Date Modified Username Field Change
2011-08-10 09:42 Julian New Issue
2011-08-10 09:56 Julian Summary Create Test Plan from existing Test Plan does not preserve linked Test Case Versions => Create Test Plan from existing Test Plan does not preserve linked Test Case Versions (keep currently linked version is checked)
2011-08-10 10:31 Julian File Added: testplan.class.php
2011-08-10 10:32 Julian Note Added: 0015647
2011-08-10 10:33 Julian File Deleted: testplan.class.php
2011-08-10 10:33 Julian File Added: testplan.class.php
2011-08-17 20:27 fman Note Added: 0015698
2011-08-18 06:26 Julian Note Added: 0015704
2011-08-18 06:26 Julian Status new => resolved
2011-08-18 06:26 Julian Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2011-08-18 06:26 Julian Resolution open => fixed
2011-08-18 06:26 Julian Assigned To => Julian
2012-09-01 20:00 fman Note Added: 0017372
2012-09-01 20:00 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker