Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004491TestLinkTest Plan (builds, milestones, test assign)public2011-05-24 09:382012-09-01 19:59
Reportertechieguy 
Assigned Tofman 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.2 (2011 Q2 - bug fixing) 
Fixed in Version1.9.4 (2012 Q3 - bug fixing) 
Summary0004491: Assign Test Case execution to users - Filtering 'Assigned to Field' does not work when builds are closed.
DescriptionCreate a Test plan.
Add Test Cases in it.
Create a build
Assign few test cases to user A, B, C
Execute those test cases, leave some of them Not RUN for any of the user.
Close Build A
Create a new build B
Assign few test cases to user A, B, C.
Execute those test cases, leave some of them Not RUN for any of the users.
Close Build A
Create a new build C.
Try to search the test cases that are NOT RUN in the BUILD A or BUILD B (choose any specific build) and were assigned to USER A. The Query returns some results.

Now just do a query for NOT RUN on LATEST EXECUTION and ASSIGNED TO USER A no Result. 0 Records.
TagsNo tags attached.
Database (MySQL,Postgres,etc)1.9.2
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesxml file icon 4491-testsuites.xml [^] (1,982 bytes) 2011-10-30 11:00
xml file icon linkedItems_TPLAN-4491.xml [^] (934 bytes) 2011-10-30 11:02
png file icon 1.9.3 Assignment Overview.png [^] (26,662 bytes) 2011-10-31 03:08


png file icon 1.9.3 Assign Testers to test execution.png [^] (22,516 bytes) 2011-10-31 03:08

- Relationships
has duplicate 0004762closedfman Assign Not Run for specific build / specific user tescases to another build. Filter does not work correctly. 
related to 0004788closedfman Test Case Execution - Give feedback when filter combination 'Result' + 'on' can not be used 
related to 0004789closedfman Test Case Execution - Filtering 'Assigned to Field' does not work due to interaction between settings & filters area 
child of 0004790closedfman Setting & Filters panel - Wrong use of BUILD on settings area 

-  Notes
(0014918)
Julian (reporter)
2011-05-24 12:24
edited on: 2011-05-24 12:24

Rework your steps please

Use different names for users and builds.

Example:
Assign 2 test cases to User1 on Build1
Assign 2 test cases to User2 on Build1
...

The way you described the issue is too hard to understand.

Please do not forget to add EXPECTED results.
We do not want to guess what you expect:
"Now just do a query for NOT RUN on LATEST EXECUTION and ASSIGNED TO USER A no Result. 0 Records."

(0014929)
techieguy (reporter)
2011-05-24 18:26

Create a Test plan.
Add Test Cases in it.
Create a build - B1
Assign 3 test cases (T1 , T2, T3) each to user A
Execute T1 test cases for A , leave T2,T3 TEST CASE Not RUN
Close Build B1

Create a new build B2
Assign 3 test cases (T1 , T2, T3) EACH to user A
Execute T2 test cases FOR A, leave T1,T3 TEST CASES Not RUN
Close Build B2

Create a new build C.
Try to search the test cases that are NOT RUN in the BUILD B1 or BUILD B2 (choose any specific build) and were assigned to USER A. The Query returns T2,T3 or T1,T3 as results.

Now just do a query for NOT RUN on LATEST EXECUTION and ASSIGNED TO USER A , no test cases are returned. IT should be T3 as output.
(0015180)
techieguy (reporter)
2011-06-08 11:49

any fix for this ?
(0015931)
fman (administrator)
2011-10-30 12:59

>> Now just do a query for NOT RUN on LATEST EXECUTION and ASSIGNED TO USER A no >> Result. 0 Records.

we need to rework user inteface options and give better help/details
why this request can not be fullfilled ?
Last execution means any value different than NOT RUN, because NOT RUN is not written to DB (Design Choice).
(0015932)
phidotnet (reporter)
2011-10-31 03:06
edited on: 2011-10-31 03:12

I reproduced the scenario on build 1.9.3 and it is failed at below steps

>>Create a new build C.
>>Try to search the test cases that are NOT RUN in the BUILD B1 or BUILD B2 (choose any specific build) and were assigned to USER A. The Query returns T2,T3 or T1,T3 as results.

Actual result:
No test case return (see attached screen shots)

(0015933)
fman (administrator)
2011-10-31 10:39
edited on: 2011-10-31 11:38

Very strange I've done config on 1.9.3 and I'm unable to reproduce.
Unfortunatelly our demo site sucks at speed then I can not offer you a common place where to do same test.

OK FOUND my possible error (need to test) BUILDS ARE NOT CLOSED

(0015935)
fman (administrator)
2011-10-31 15:20
edited on: 2011-10-31 15:34

@phidotnet
Just created a test project on our demo site
http://testlink.sourceforge.net/demo/index.php [^]

Done following test:

  1. Create a Test plan.
  2. Add 3 Test Cases.
  3. Create a build - B1,B2,C,B1-TO-BE_CLOSED,B2-TO_BE_CLOSED
  4. Assign 3 test cases (T1 , T2, T3) to user 'user A'
  5. Execute T1 test case, leave T2,T3 TEST CASE Not RUN (using admin login)
  6. Close Build B1
  7. Go to execution feature
  8. B1 is not more available on build combo on SETTINGS AREA
  9. B1 is available on build combo on FILTERS AREA when I do following choice: Result: Not Run, On: Specific Build
  10. If assigned to = ANY => things work => GOT T2, T3
  11. If assigned to = User A => got 0 RECORDS => KO.


Seems there is an interaction between BUILD CHOICE on settings area and BUILD choice on FILTER AREA, and this is WRONG.
BUILD CHOICE on SETTINGS AREA has to be used on FILTERS ONLY for this choice:


Results: xxx

on: Build Chosen for execution



on any other situation has to be IGNORED

(0015936)
fman (administrator)
2011-10-31 16:54
edited on: 2011-10-31 17:11

Quick fix - treeMenu.inc.php
Comment
$build2filter_assignments = isset($filters->setting_build) ? $filters->setting_build : 0;
$build_id = isset($filters->filter_result_build) ?$filters->filter_result_build : null;

Add
$buildSettingsPanel = isset($filters->setting_build) ? $filters->setting_build : 0;
$buildFiltersPanel = isset($filters->filter_result_build) ? $filters->filter_result_build : null;
$build2filter_assignments = is_null($buildFiltersPanel) ? $buildSettingsPanel : $buildFiltersPanel;

Thanks @phidotnet, for his work

(0017364)
fman (administrator)
2012-09-01 19:59

1.9.4 released

- Issue History
Date Modified Username Field Change
2011-05-24 09:38 techieguy New Issue
2011-05-24 12:24 Julian Note Added: 0014918
2011-05-24 12:24 Julian Note Edited: 0014918 View Revisions
2011-05-24 18:26 techieguy Note Added: 0014929
2011-06-08 11:49 techieguy Note Added: 0015180
2011-10-30 11:00 fman File Added: 4491-testsuites.xml
2011-10-30 11:02 fman File Added: linkedItems_TPLAN-4491.xml
2011-10-30 12:59 fman Note Added: 0015931
2011-10-31 03:06 phidotnet Note Added: 0015932
2011-10-31 03:07 phidotnet Note Edited: 0015932 View Revisions
2011-10-31 03:08 phidotnet File Added: 1.9.3 Assignment Overview.png
2011-10-31 03:08 phidotnet File Added: 1.9.3 Assign Testers to test execution.png
2011-10-31 03:12 phidotnet Note Edited: 0015932 View Revisions
2011-10-31 10:39 fman Note Added: 0015933
2011-10-31 11:38 fman Note Edited: 0015933 View Revisions
2011-10-31 11:43 fman Issue cloned: 0004788
2011-10-31 11:43 fman Relationship added related to 0004788
2011-10-31 15:20 fman Note Added: 0015935
2011-10-31 15:24 fman Note Edited: 0015935 View Revisions
2011-10-31 15:34 fman Note Edited: 0015935 View Revisions
2011-10-31 15:36 fman Summary Filtering in Test Case Assignment doesnt work for Assigned to Field in some cases. => Assign Test Case execution to users - Filtering 'Assigned to Field' does not work when builds are closed.
2011-10-31 15:38 fman Issue cloned: 0004789
2011-10-31 15:38 fman Relationship added related to 0004789
2011-10-31 16:51 fman Relationship added child of 0004790
2011-10-31 16:54 fman Note Added: 0015936
2011-10-31 16:54 fman Note Edited: 0015936 View Revisions
2011-10-31 17:11 fman Note Edited: 0015936 View Revisions
2011-10-31 17:11 fman Status new => resolved
2011-10-31 17:11 fman Fixed in Version => 1.9.4 (2012 Q3 - bug fixing)
2011-10-31 17:11 fman Resolution open => fixed
2011-10-31 17:11 fman Assigned To => fman
2011-11-11 19:41 fman Relationship added has duplicate 0004762
2012-09-01 19:59 fman Note Added: 0017364
2012-09-01 19:59 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker