Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004470TestLinkTest Executepublic2011-05-12 18:022011-07-02 13:49
Reporteraostad 
Assigned ToJulian 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindowsOSWin 7OS Version
Product Version1.9.2 (2011 Q2 - bug fixing) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004470: single (' ')and double (" ")qoute are shown with a backslash ( \ ) in Test Execution trees
DescriptionIf the title of a test case has a ' or " it will be shows like this \' or \". while in Test Specification this is not a case.
Steps To Reproduce1-Write e test case with ' or " in the title
2-check out the title in Test Execution page
TagsNo tags attached.
Database (MySQL,Postgres,etc)Mysql
BrowserFirefox
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Filesjpg file icon Testlink issue-test execution page.jpg [^] (45,266 bytes) 2011-05-12 18:02

- Relationships
child of 0004337closedfman Availables Fixes for 1.9.2 (Prague) 

-  Notes
(0014852)
Julian (reporter)
2011-05-12 18:56

I can reproduce
(0014853)
fman (administrator)
2011-05-12 19:01

some sort of Javascript escaping, old issue
(0014856)
Julian (reporter)
2011-05-13 10:17
edited on: 2011-05-13 10:17

This also happens for filtered test specification tree.

Please comment line
$str = addslashes($str);
on function filterString() in lib/functions/treeMenu.inc.php

Francisco is this a potential fix or what was the reason of this function call.

(0014857)
fman (administrator)
2011-05-13 10:45

@Julian:
who knows when and who has added this ? nobody that's why comments ARE CRITIC.
Only reason I can give you is:
sometime ago we were so cleaver enough to offer users 3 different type of menu manager, may be one of it wants this.
Then ?
do the change and will see (hope Zero side effect)

Thanks for effort

Francisco
(0014859)
Julian (reporter)
2011-05-13 11:08

commented mentioned line.
Please give feedback if side-effects occur.

Branch 1.9:
http://gitorious.org/testlink-ga/testlink-code/commit/5bf091be7ad2cd2fd3ad521719b5cb62c092942c [^]

Master:
http://gitorious.org/testlink-ga/testlink-code/commit/38294a7111410bb01ee3192fb0009e12738598b1 [^]
(0015450)
fman (administrator)
2011-07-02 13:49

1.9.3 released

- Issue History
Date Modified Username Field Change
2011-05-12 18:02 aostad New Issue
2011-05-12 18:02 aostad File Added: Testlink issue-test execution page.jpg
2011-05-12 18:56 Julian Note Added: 0014852
2011-05-12 18:56 Julian Assigned To => Julian
2011-05-12 18:56 Julian Status new => acknowledged
2011-05-12 19:01 fman Note Added: 0014853
2011-05-13 10:17 Julian Note Added: 0014856
2011-05-13 10:17 Julian Note Edited: 0014856 View Revisions
2011-05-13 10:45 fman Note Added: 0014857
2011-05-13 11:08 Julian Note Added: 0014859
2011-05-13 11:08 Julian Status acknowledged => resolved
2011-05-13 11:08 Julian Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-05-13 11:08 Julian Resolution open => fixed
2011-05-13 11:09 Julian Relationship added child of 0004337
2011-07-02 13:49 fman Note Added: 0015450
2011-07-02 13:49 fman Status resolved => closed



Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker