Mantis Bugtracker          
testlink.org

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004459TestLinkReportspublic2011-05-06 15:582011-07-02 13:49
Reporteralert_qc 
Assigned ToJulian 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.9.2 (2011 Q2 - bug fixing) 
Fixed in Version1.9.3 (2011 Q3 - bug fixing) 
Summary0004459: Failed Test Cases Report
Descriptionbuild dont show up to group by
Additional InformationI fixed it with:

//NF: START
                 $build_mgr = new build_mgr($db);
                if (isset($testcase['exec_on_build'])) {
                    $build_info = $build_mgr->get_by_id($testcase['exec_on_build']);
                    $testcase['assigned_build_name'] = $build_info['name'];
                } else {
                    $testcase['assigned_build_name'] = lang_get('unassigned');
                }
              //NF: END




on the else of this if:

if( $args->type == $statusCode['not_run'] )
        


file: resultsByStatus.php




Also noticed that on the same report, the execute link, was using the wrong build id.



Fixed it with:

if (isset($testcase['build_id'])) {
                $build_id = $testcase['build_id'];
            }
            //NF:
                else if (isset($testcase['exec_on_build'])) {
                 $build_id = $testcase['exec_on_build'];
                }
                else if (isset($testcase['assigned_build_id'])) {
                $build_id = $testcase['assigned_build_id'];
            }
TagsNo tags attached.
Database (MySQL,Postgres,etc)MySQL
Browser
PHP Version
TestCaseID
QA Team - Task Workflow Status
Attached Files

- Relationships
duplicate of 0004343closedfman Reports Failed Test Cases / Blocked Test Cases / Not Run Test Cases -> Build is not shown 

-  Notes
(0014862)
Julian (reporter)
2011-05-13 11:18

Issue is not clear. Describe what is wrong. Provide us proper steps to reproduce.

Without understanding the problem we cannot use the solution.
(0014867)
alert_qc (reporter)
2011-05-13 13:45

The report: Failed Test Cases

doesn't show the builds (test case not assigned, just executed)


The other issue on the same report is, the link to execute again the test case, is using an incorrect build.
(0014868)
Julian (reporter)
2011-05-13 13:47

these are no steps to reproduce...

duplicate of 0004343 ?
(0014870)
fman (administrator)
2011-05-13 19:18

@user:
last chance to provide detailed steps to reproduce before issue will be closed by development team
(0014893)
Julian (reporter)
2011-05-21 06:41

No feedback - we assume it is a duplicate of 0004343
(0015448)
fman (administrator)
2011-07-02 13:49

1.9.3 released

- Issue History
Date Modified Username Field Change
2011-05-06 15:58 alert_qc New Issue
2011-05-13 11:18 Julian Note Added: 0014862
2011-05-13 13:45 alert_qc Note Added: 0014867
2011-05-13 13:47 Julian Note Added: 0014868
2011-05-13 19:18 fman Note Added: 0014870
2011-05-21 06:41 Julian Note Added: 0014893
2011-05-21 06:41 Julian Relationship added duplicate of 0004343
2011-05-21 06:41 Julian Status new => resolved
2011-05-21 06:41 Julian Fixed in Version => 1.9.3 (2011 Q3 - bug fixing)
2011-05-21 06:41 Julian Resolution open => fixed
2011-05-21 06:41 Julian Assigned To => Julian
2011-07-02 13:49 fman Note Added: 0015448
2011-07-02 13:49 fman Status resolved => closed



Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker